geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jacek Laskowski" <ja...@laskowski.net.pl>
Subject Re: What is the Java Version for building source code?
Date Fri, 30 Mar 2007 06:22:00 GMT
On 3/30/07, Lasantha Ranaweera <lasantha@opensource.lk> wrote:
> Hi,
>
> What is the recommended Java version to be used with building G from
> source code?
>
> At the moment I am having a problem of building G from source code
> (maven build fails with complaining incompatible Java version).
> Following is my JDK information.
>
> java version "1.5.0_07"
> Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_07-b03)
> Java HotSpot(TM) Server VM (build 1.5.0_07-b03, mixed mode)

$ java -version
java version "1.5.0_11"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_11-b03)
Java HotSpot(TM) Client VM (build 1.5.0_11-b03, mixed mode, sharing)

That's what I'm using with no issues. I don't think it's the version
of Java you're using. Make sure that M2 doesn't grab other version
available on your system. 1.5.* should be fine (I haven't looked at
the plugin's code, though. It's been a while when I did).

Jacek

-- 
Jacek Laskowski
http://www.JacekLaskowski.pl

Mime
View raw message