geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kanchana Welagedara <kanch...@opensource.lk>
Subject Re: [test]How to update files in .m2/repository
Date Tue, 06 Mar 2007 07:35:02 GMT
On Tue, 2007-03-06 at 15:25 +0800, Sean Qiu wrote:
> What's the problem of this?
> I have try many times to delete the old ones, but it still remains the
> same error.

Remove the complaining stuff from the .m2 repository ,double check
whether it's removed and get svn update  before building the code again.
are you using 

$mvn -Dmaven.test.skip=true -e clean install to build the code?

cheers
Kanchana
> Time to build schema type system: 1.056 seconds
> Time to generate code: 0.266 seconds
> error: error
> reading /home/qbit/.m2/repository/org/apache/openejb/container/3.0-incubating-SNAPSHOT/container-
3.0-incubating-SNAPSHOT.pom; error in opening zip file
> Note: Some input files use or override a deprecated API.
> Note: Recompile with -Xlint:deprecation for details.
> 1 error
> 
> BUILD FAILED
> [INFO]
> ------------------------------------------------------------------------ 
> [ERROR] BUILD ERROR
> [INFO]
> ------------------------------------------------------------------------
> [INFO] XmlBeans compile failed:
> xml ErrorLoading schema
> file /home/qbit/at/geronimo/server/modules/geronimo-corba-builder/src/main/schema/corba-
css-config-2.1.xsd
> xml ErrorLoading schema
> file /home/qbit/at/geronimo/server/modules/geronimo-corba-builder/src/main/schema/corba-tss-config-2.1.xsd
> xml ErrorLoading config
> file /home/qbit/at/geronimo/server/modules/geronimo-corba-builder/src/main/schema/xmlconfig.xml

> 
> 
> 
> 2007/3/6, Sean Qiu <sean.xx.qiu@gmail.com>:
>         It seems the dependency in directory of ".m2/repository" is
>         prone to be outdated.
>         When i execute "svn up" and "mvn clean install". It will
>         report some problem from .m2/repository like:
>         >>>>>>>> 
>         error: error
>         reading /home/qbit/.m2/repository/org/apache/openejb/container/3.0-incubating-SNAPSHOT/container-3.0-incubating-SNAPSHOT.pom;
error in opening zip file
>         Note: Some input files use or override a deprecated API. 
>         Note: Recompile with -Xlint:deprecation for details.
>         
>         How to update the files in .m2/repository individously?
>         
>         Thanks, best regards.
>         
>         -- 
>         Sean Qiu 
> 
> 
> 
> -- 
> Sean Qiu 


Mime
View raw message