Lasantha...

I just checked out the current revision of Daytrader from trunk and was able to deploy on both Geronimo 1.2-beta and 2.0-M1. I placed the plan files I used for each in the following location.

http://people.apache.org/~cjblythe/daytrader_plan_files/

Let me know if you still run into problems... Unfortunately, deployment is highly dependent upon the plan files and as each new branch/tag of Geronimo is released, the plan files have to be modified slightly to adjust for changes in the version names/levels of the dependent rar files in Geronimo. It would be really nice if we could specify the rar file in the plan files without specifying a version. Any thoughts if it is possible?

Matt... I haven't tried deploying against M2 yet. Is that where you are running into problems?

Thanks...

Chris

On 2/13/07, Lasantha Ranaweera <lasantha@opensource.lk> wrote:
Matt,

Thanks for the info. I will wait until you finish it. That will make my
life more easier. Until then web services & documentation ..... ;)

Please inform the list when are sorted it out.

Thanks Again,
Lasantha

> Lasantha
>
> I'm working through some build issues with DT right now.  I'd suggest
> waiting till I sort them out.  If you want to work on them as well I
> had to go back in the time machine to a DayTrader build off of trunk
> from December:
>
> svn co -r 486035 https://svn.apache.org/repos/asf/geronimo/daytrader/
> trunk@486035 daytrader/trunk
>
> I'll be sorting though where I went awry but won't get to it for a
> day or so.  I think when applying some patches things went bad and it
> no longer deploys after the rev number above.  I'll get it sorted out
> in the next day or so.  You can use the plan at http://svn.apache.org/
> repos/asf/geronimo/daytrader/trunk/plans/ daytrader-2.0-M1-jpa-
> plan.xml with a few tweaks to the rar artifact versions and that
> might work.
>
> Anyway, should have it sorted when I get back.
>
> On Feb 13, 2007, at 5:06 AM, Lasantha Ranaweera wrote:
>
>> Hi Guys,
>>
>> I missed a mail posted by Matt :-) . I found the answer is there.
>> It says daytrader is working on 1.2 beta of G. But the geronimo-
>> web.xml provided in the DayTrader trunk is looks like compatible
>> with 1.0 of G. Am I missing something here?
>>
>> Thanks,
>> Lasantha
>>
>> Lasantha Ranaweera wrote:
>>> Hi All,
>>>
>>> This is yet another daytrader newbie question. What is the Geronimo
>>> version current Daytrader trunk has been testing on?
>>>
>>>
>>> Thanks,
>>> Lasantha Ranaweera
>>>
>>>
>>
>>
>
>




--
"I say never be complete, I say stop being perfect, I say let... lets evolve, let the chips fall where they may." - Tyler Durden