geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Prasad Kashyap" <goyathlay.geron...@gmail.com>
Subject Re: openejb with geronimo issues
Date Mon, 19 Feb 2007 19:43:06 GMT
On 2/19/07, Jarek Gawor <jgawor@gmail.com> wrote:
> I have noticed a few issues with openejb and geronimo and I was
> wondering what is the status of these problems or if I'm doing
> something wrong. I think some of these might already be known issues:
>
> 1) Redeployment of the same EJB fails with:
>
> Deployer operation failed:
> org.apache.geronimo.kernel.config.ConfigurationAlreadyExistsException:
> Configuration already exists: XXXX

http://www.nabble.com/forum/ViewPost.jtp?post=8979764&framed=y

>
> 2) If there is an openejb-jar.xml file in the archive (with
> dependency/moduleId element) I see the following message in the
> container:
>
> [severity=ERROR,message=unexpected element (uri:"http://www.openejb.org/openejb-
> jar/1.1", local:"environment"). Expected elements are <{http://www.openejb.org/o
> penejb-jar/1.1}ejb-deployment>,locator=[node=null,object=null,url=null,line=25,c
> ol=18,offset=-1]]

http://www.nabble.com/forum/ViewPost.jtp?post=8972201&framed=y

>
> 3) I'm unable to lookup the EJB from a J2SE client application (not
> app client container). This used to work with OpenEJB2 and I don't
> know if the mapping has changed (I've tried different combinations
> with no success) or if that does not work yet.
>
> Can somebody clarify?
>
> Thanks,
> Jarek
>

Mime
View raw message