geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Donald Woods <drw_...@yahoo.com>
Subject Build failure with eclipse-plugin trunk Rev509704
Date Wed, 21 Feb 2007 02:20:08 GMT
I'm getting the following build error when trying to build the latest 
Eclipse plug-in code from trunk on WinXP and SUSE Linux with a clean m2 
repo and after building the latest 2.0 server -

[ERROR] BUILD ERROR
[INFO] 
------------------------------------------------------------------------
[INFO] Failed to resolve artifact.
Missing:
----------
1) org.apache.geronimo.specs:geronimo-qname_1.1_spec:test:1.0.1
   Try downloading the file manually from the project website.
   Then, install it using the command:
       mvn install:install-file -DgroupId=org.apache.geronimo.specs 
-DartifactId=geronimo-qname_1.1_spec \
           -Dversion=1.0.1 -Dpackaging=test -Dfile=/path/to/file
   Path to dependency:
   	1) org.apache.geronimo.devtools:geronimo-1.1-emf:jar:1.0
   	2) openejb:openejb-pkgen-builder:jar:2.1.1
   	3) geronimo:geronimo-kernel:jar:1.1.1
   	4) org.apache.geronimo.specs:geronimo-qname_1.1_spec:test:1.0.1
----------
1 required artifact is missing.
for artifact:
   org.apache.geronimo.devtools:geronimo-1.1-emf:jar:1.0
from the specified remote repositories:
   central (http://repo1.maven.org/maven2),
   apache.incubator 
(http://people.apache.org/repo/m2-incubating-repository/),
   sppatel (http://people.apache.org/~sppatel/maven/repository/),
   apache-snapshots (http://people.apache.org/repo/m2-snapshot-repository),
   codehaus-snapshots (http://snapshots.repository.codehaus.org)
[INFO] 
------------------------------------------------------------------------


Is it really supposed to be "-Dpackaging=test" or should it be "jar"?


-Donald


Mime
View raw message