geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tim McConnell <tim.mcco...@gmail.com>
Subject Correct ClassFinder version
Date Wed, 14 Feb 2007 06:10:57 GMT
Hi David, Is the 2.8 version of xbean-finder.jar the correct version to use 
for Geronimo ?? I notice there is a 2.9 version available and when I use 
the 2.8 version with a clean m2 repo I get the errors below. Thanks.

[INFO] ------------------------------------------------------------------------
[ERROR] BUILD FAILURE
[INFO] ------------------------------------------------------------------------
[INFO] Compilation failure

C:\SVN\G\server\trunk\modules\geronimo-j2ee-builder\src\main\java\org\apache\geronimo\j2ee\deployment\annotation\EJBAnnotationHelper.java:[173,24]

cannot find symbol
symbol  : method isAnnotationPresent(java.lang.Class<javax.ejb.EJB>)
location: class org.apache.xbean.finder.ClassFinder

C:\SVN\G\server\trunk\modules\geronimo-j2ee-builder\src\main\java\org\apache\geronimo\j2ee\deployment\annotation\EJBAnnotationHelper.java:[174,24]

cannot find symbol
symbol  : method isAnnotationPresent(java.lang.Class<javax.ejb.EJBs>)
location: class org.apache.xbean.finder.ClassFinder

-- 
Thanks,
Tim McConnell

Mime
View raw message