geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Aman Nanner (JIRA)" <j...@apache.org>
Subject [jira] Commented: (GERONIMO-2742) Deployer cannot access libaries in shared/lib and shared/classes
Date Thu, 08 Feb 2007 14:33:05 GMT

    [ https://issues.apache.org/jira/browse/GERONIMO-2742?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_12471341
] 

Aman Nanner commented on GERONIMO-2742:
---------------------------------------

Hi Rakesh,

I neglected to include the jgroups.jar archive, which is why you were getting the NoClassDefFound
error for org.jgroups.MembershipListener.

I'm surprised that you got that far though....my deployment was still failing with a NoClassDefFound
error on org.jboss.cache.TreeCacheMBean.  I am currently testing this against Geronimo 1.2-beta,
and using "offline" and "inPlace" deployment.

It seems that, during runtime, the server can pick up the classes from the shared lib folder,
but the deployment process cannot for some reason.

> Deployer cannot access libaries in shared/lib and shared/classes
> ----------------------------------------------------------------
>
>                 Key: GERONIMO-2742
>                 URL: https://issues.apache.org/jira/browse/GERONIMO-2742
>             Project: Geronimo
>          Issue Type: Bug
>      Security Level: public(Regular issues) 
>          Components: deployment
>    Affects Versions: 1.2
>         Environment: Windows XP, Geronimo 1.2-beta
>            Reporter: Aman Nanner
>         Attachments: sharedlib-2.0.zip, sharedlib.zip, testing.ear.zip
>
>
> It seems that when running the deployer to deploy my EAR file, the classloaders during
deployment cannot access the shared/lib and shared/classes directory.  My app has dependencies
on libraries that are stored in both shared/classes and shared/lib.  Because these libraries
cannot be found, the deployment fails.
> Neither regular deployment nor hot deployment works.  My EAR file used to hot deploy
properly in Geronimo 1.1.1 (I never used the regular deployer in 1.1.1, so I don't know if
that would have worked too).

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message