geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jason Dillon (JIRA)" <j...@apache.org>
Subject [jira] Commented: (GERONIMO-2881) Client-Transaction explicit-versions.properties does not include all dependencies.
Date Sat, 24 Feb 2007 01:42:05 GMT

    [ https://issues.apache.org/jira/browse/GERONIMO-2881?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_12475569
] 

Jason Dillon commented on GERONIMO-2881:
----------------------------------------

Where does the build fail?  I just tried a build of 2.0-m3 with a clean repo (and fresh co)
and its gotten past all configs and is building assemblies now... and I see bits like:

{noformat}
org.apache.geronimo.modules/geronimo-core//jar=org.apache.geronimo.modules/geronimo-core/2.0-M3-SNAPSHOT/jar
{noformat}

In the {{configs/client-transaction/target/explicit-versions.properties}} file...

So, not sure what error you are seeing.

> Client-Transaction explicit-versions.properties does not include all dependencies.
> ----------------------------------------------------------------------------------
>
>                 Key: GERONIMO-2881
>                 URL: https://issues.apache.org/jira/browse/GERONIMO-2881
>             Project: Geronimo
>          Issue Type: Bug
>      Security Level: public(Regular issues) 
>          Components: Maven Plugins for G
>    Affects Versions: 2.0-beta1
>         Environment: All (I think)
>            Reporter: Matt Hogstrom
>         Assigned To: Jason Dillon
>             Fix For: 2.0-beta1
>
>
> When working on the branch I ran into a problem in configs/client-transaction where the
build failed because geronimo-ejb_3.0_specs//car could not be resolved.  In looking at the
generated explicit-versions.properties this entry was missing.  I looked at the Maven dependencies
for that module and found that all dependencies under geronimo-transaction were missing in
the explicit versions.
> Here are the Maven dependencies:
> {noformat}
> [INFO] org.apache.geronimo.configs:client-transaction:car { version=2.0-M3-SNAPSHOT,
scope=null }
> [INFO]     junit:junit:jar { version=3.8.1, scope=test }
> [INFO]     org.apache.geronimo.genesis.config:logging-config:jar { version=1.1, scope=test
}
> [INFO]     org.apache.geronimo.modules:geronimo-transaction:jar { version=2.0-M3-SNAPSHOT,
scope=compile }
> {noformat}
> These are not included in the explicit-version.properties file that is generated:
> {noformat}
> [INFO]         org.apache.geronimo.modules:geronimo-core:jar { version=2.0-M3-SNAPSHOT,
scope=compile }
> [INFO]         org.apache.geronimo.modules:geronimo-j2ee:jar { version=2.0-M3-SNAPSHOT,
scope=compile }
> [INFO]         org.apache.geronimo.specs:geronimo-jta_1.1_spec:jar { version=1.0, scope=compile
}
> [INFO]         org.apache.geronimo.specs:geronimo-ejb_3.0_spec:jar { version=1.0, scope=compile
}
> [INFO]         org.apache.geronimo.specs:geronimo-j2ee-connector_1.5_spec:jar { version=1.1,
scope=compile }
> [INFO]         backport-util-concurrent:backport-util-concurrent:jar { version=2.2, scope=compile
}
> [INFO]         org.objectweb.howl:howl:jar { version=1.0.1-1, scope=compile }
> {noformat}
> Resume included dependencies:
> {noformat}
> [INFO]     org.apache.geronimo.configs:client:car { version=2.0-M3-SNAPSHOT, scope=compile
}
> [INFO]         org.apache.geronimo.configs:client-system:car { version=2.0-M3-SNAPSHOT,
scope=compile }
> [INFO]             org.apache.geronimo.specs:geronimo-j2ee-management_1.1_spec:jar {
version=1.0-SNAPSHOT, scope=compile }
> [INFO]         org.apache.geronimo.configs:jee-specs:car { version=2.0-M3-SNAPSHOT, scope=compile
}
> [INFO]             org.apache.geronimo.specs:geronimo-activation_1.1_spec:jar { version=1.0-SNAPSHOT,
scope=compile }
> [INFO]             org.apache.geronimo.specs:geronimo-annotation_1.0_spec:jar { version=1.0,
scope=compile }
> [INFO]             org.apache.geronimo.specs:geronimo-el_1.0_spec:jar { version=1.0-SNAPSHOT,
scope=compile }
> [INFO]             org.apache.geronimo.specs:geronimo-jacc_1.1_spec:jar { version=1.0-SNAPSHOT,
scope=compile }
> [INFO]             org.apache.geronimo.javamail:geronimo-javamail_1.4_mail:jar { version=1.0-SNAPSHOT,
scope=compile }
> [INFO]                 org.apache.geronimo.javamail:geronimo-javamail_1.4_provider:jar
{ version=1.0-SNAPSHOT, scope=compile }
> [INFO]                 org.apache.geronimo.specs:geronimo-javamail_1.4_spec:jar { version=1.0-SNAPSHOT,
scope=compile }
> [INFO]             org.apache.geronimo.specs:geronimo-jaxrpc_1.1_spec:jar { version=1.1,
scope=compile }
> [INFO]             org.apache.geronimo.specs:geronimo-jaxr_1.0_spec:jar { version=1.1,
scope=compile }
> [INFO]             org.apache.geronimo.specs:geronimo-jms_1.1_spec:jar { version=1.1,
scope=compile }
> [INFO]             org.apache.geronimo.specs:geronimo-jsp_2.1_spec:jar { version=1.0-SNAPSHOT,
scope=compile }
> [INFO]             org.apache.geronimo.specs:geronimo-saaj_1.1_spec:jar { version=1.1,
scope=compile }
> [INFO]             org.apache.geronimo.specs:geronimo-servlet_2.5_spec:jar { version=1.1-SNAPSHOT,
scope=compile }
> [INFO]             stax:stax-api:jar { version=1.0.1, scope=compile }
> [INFO]             javax.xml.bind:jaxb-api:jar { version=2.0, scope=compile }
> [INFO]             org.apache.geronimo.specs:geronimo-ws-metadata_2.0_spec:jar { version=1.1-SNAPSHOT,
scope=compile }
> [INFO]             javax.xml.ws:jaxws-api:jar { version=2.0, scope=compile }
> [INFO]         org.apache.geronimo.modules:geronimo-activation:jar { version=2.0-M3-SNAPSHOT,
scope=compile }
> [INFO]         org.apache.geronimo.modules:geronimo-interceptor:jar { version=2.0-M3-SNAPSHOT,
scope=compile }
> [INFO]         org.apache.geronimo.modules:geronimo-naming:jar { version=2.0-M3-SNAPSHOT,
scope=compile }
> [INFO]             org.apache.xbean:xbean-naming:jar { version=2.8, scope=compile }
> [INFO]         org.apache.geronimo.modules:geronimo-management:jar { version=2.0-M3-SNAPSHOT,
scope=compile }
> [INFO]         org.apache.geronimo.modules:geronimo-security:jar { version=2.0-M3-SNAPSHOT,
scope=compile }
> [INFO]         org.apache.geronimo.modules:geronimo-util:jar { version=2.0-M3-SNAPSHOT,
scope=compile }
> [INFO]             commons-logging:commons-logging:jar { version=1.0.4, scope=compile
}
> [INFO]         org.apache.geronimo.modules:geronimo-client:jar { version=2.0-M3-SNAPSHOT,
scope=compile }
> [INFO]         org.apache.geronimo.modules:geronimo-axis:jar { version=2.0-M3-SNAPSHOT,
scope=compile }
> [INFO]             org.apache.geronimo.modules:geronimo-openejb:jar { version=2.0-M3-SNAPSHOT,
scope=compile }
> [INFO]                 org.apache.openejb:openejb-core:jar { version=3.0-incubating-SNAPSHOT,
scope=compile }
> [INFO]                     org.apache.geronimo.specs:geronimo-jpa_3.0_spec:jar { version=1.0,
scope=compile }
> [INFO]                     org.apache.openejb:openejb-loader:jar { version=3.0-incubating-SNAPSHOT,
scope=compile }
> [INFO]                     org.apache.openejb:openejb-javaagent:jar { version=3.0-incubating-SNAPSHOT,
scope=compile }
> [INFO]                     org.apache.openejb:openejb-jee:jar { version=3.0-incubating-SNAPSHOT,
scope=compile }
> [INFO]                     org.apache.activemq:activemq-ra:jar { version=4.1.0-incubator,
scope=compile }
> [INFO]                         activemq:jmdns:jar { version=1.0-RC2, scope=compile }
> [INFO]                     org.apache.activemq:activemq-core:jar { version=4.1.0-incubator,
scope=compile }
> [INFO]                     org.codehaus.castor:castor:jar { version=1.0.5, scope=compile
}
> [INFO]                     xerces:xercesImpl:jar { version=2.8.1, scope=compile }
> [INFO]                     commons-logging:commons-logging-api:jar { version=1.0.4, scope=compile
}
> [INFO]                     oro:oro:jar { version=2.0.8, scope=compile }
> [INFO]                     org.apache.openjpa:openjpa-persistence-jdbc:jar { version=0.9.6-incubating,
scope=compile }
> [INFO]                         org.apache.openjpa:openjpa-jdbc-5:jar { version=0.9.6-incubating,
scope=compile }
> [INFO]                             org.apache.openjpa:openjpa-jdbc:jar { version=0.9.6-incubating,
scope=compile }
> [INFO]                                 org.apache.openjpa:openjpa-kernel:jar { version=0.9.6-incubating,
scope=compile }
> [INFO]                                     org.apache.openjpa:openjpa-lib:jar { version=0.9.6-incubating,
scope=compile }
> [INFO]                                         commons-lang:commons-lang:jar { version=2.0,
scope=compile }
> [INFO]                                         ant:ant:jar { version=1.6.5, scope=compile
}
> [INFO]                                         net.sourceforge.serp:serp:jar { version=1.11.0,
scope=compile }
> [INFO]                                     commons-pool:commons-pool:jar { version=1.3,
scope=compile }
> [INFO]                                 hsqldb:hsqldb:jar { version=1.7.2.2, scope=compile
}
> [INFO]                         org.apache.openjpa:openjpa-persistence:jar { version=0.9.6-incubating,
scope=compile }
> [INFO]                             org.apache.openjpa:openjpa-kernel-5:jar { version=0.9.6-incubating,
scope=compile }
> [INFO]                             javax.persistence:persistence-api:jar { version=1.0,
scope=compile }
> [INFO]                     org.apache.geronimo.specs:geronimo-interceptor_3.0_spec:jar
{ version=1.0, scope=compile }
> [INFO]                     org.apache.geronimo.specs:geronimo-j2ee-deployment_1.1_spec:jar
{ version=1.0.1, scope=compile }
> [INFO]                     org.apache.xbean:xbean-reflect:jar { version=2.8, scope=compile
}
> [INFO]                     org.apache.xbean:xbean-finder:jar { version=2.9-SNAPSHOT,
scope=compile }
> [INFO]                     asm:asm-commons:jar { version=2.2.3, scope=compile }
> [INFO]                         asm:asm-tree:jar { version=2.2.3, scope=compile }
> [INFO]                     org.tranql:tranql:jar { version=1.4.1, scope=compile }
> [INFO]                         antlr:antlr:jar { version=2.7.2, scope=compile }
> [INFO]                         commons-collections:commons-collections:jar { version=3.1,
scope=compile }
> [INFO]                         commons-primitives:commons-primitives:jar { version=20041207.202534,
scope=compile }
> [INFO]                     org.codehaus.swizzle:swizzle-stream:jar { version=1.0.1, scope=compile
}
> [INFO]                     org.springframework:spring:jar { version=2.0, scope=compile
}
> [INFO]                 org.apache.openejb:openejb-ejbd:jar { version=3.0-incubating-SNAPSHOT,
scope=compile }
> [INFO]                 org.apache.openejb:openejb-client:jar { version=3.0-incubating-SNAPSHOT,
scope=compile }
> [INFO]             org.apache.openejb:openejb-axis:jar { version=3.0-incubating-SNAPSHOT,
scope=compile }
> [INFO]                 org.apache.openejb:container:pom { version=3.0-incubating-SNAPSHOT,
scope=compile }
> [INFO]                 org.apache.openejb:openejb-server:jar { version=3.0-incubating-SNAPSHOT,
scope=compile }
> [INFO]             asm:asm:jar { version=2.2.3, scope=compile }
> [INFO]             axis:axis:jar { version=1.4, scope=compile }
> [INFO]                 axis:axis-jaxrpc:jar { version=1.4, scope=compile }
> [INFO]                 axis:axis-saaj:jar { version=1.4, scope=compile }
> [INFO]                 axis:axis-wsdl4j:jar { version=1.5.1, scope=runtime }
> [INFO]             commons-discovery:commons-discovery:jar { version=0.2, scope=compile
}
> [INFO]             wsdl4j:wsdl4j:jar { version=1.6.1, scope=compile }
> [INFO]         org.apache.geronimo.modules:geronimo-webservices:jar { version=2.0-M3-SNAPSHOT,
scope=compile }
> [INFO]             castor:castor:jar { version=0.9.5.3, scope=compile }
> [INFO]             xfire:xfire:jar { version=20050202, scope=compile }
> [INFO]             xfire:xfire-java:jar { version=20050202, scope=compile }
> [INFO]         scout:scout:jar { version=0.5, scope=compile }
> [INFO]         juddi:juddi:jar { version=0.9rc4, scope=compile }
> [INFO]         org.codehaus.woodstox:wstx-asl:jar { version=3.2.0, scope=compile }
> [INFO]         com.sun.xml.bind:jaxb-impl:jar { version=2.0.3, scope=compile }
> [INFO]             javax.activation:activation:jar { version=1.1, scope=compile }
> [INFO]         activeio:activeio:jar { version=2.0-r118, scope=compile }
> [INFO]         concurrent:concurrent:jar { version=1.3.4, scope=compile }
> [INFO]     org.apache.geronimo.modules:geronimo-connector:jar { version=2.0-M3-SNAPSHOT,
scope=compile }
> [INFO]         org.apache.geronimo.modules:geronimo-deployment:jar { version=2.0-M3-SNAPSHOT,
scope=compile }
> [INFO]             xmlbeans:xbean:jar { version=2.0.0, scope=compile }
> [INFO]             xml-resolver:xml-resolver:jar { version=1.1, scope=compile }
> [INFO]         org.apache.geronimo.modules:geronimo-common:jar { version=2.0-M3-SNAPSHOT,
scope=compile }
> [INFO]         org.apache.geronimo.modules:geronimo-kernel:jar { version=2.0-M3-SNAPSHOT,
scope=compile }
> [INFO]             cglib:cglib-nodep:jar { version=2.1_3, scope=compile }
> [INFO]             log4j:log4j:jar { version=1.2.14, scope=compile }
> [INFO]             mx4j:mx4j:jar { version=3.0.1, scope=compile }
> [INFO]             xstream:xstream:jar { version=1.1.3, scope=compile }
> [INFO]             xpp3:xpp3:jar { version=1.1.3.3, scope=compile }
> [INFO]         regexp:regexp:jar { version=1.3, scope=compile }
> [INFO]     org.apache.geronimo.modules:geronimo-transaction-jta11:jar { version=2.0-M3-SNAPSHOT,
scope=compile }
> [INFO]         org.apache.geronimo.modules:geronimo-system:jar { version=2.0-M3-SNAPSHOT,
scope=compile }
> [INFO]             commons-jexl:commons-jexl:jar { version=1.1, scope=compile }
> [INFO]             ognl:ognl:jar { version=2.6.9, scope=compile }
> [INFO] ------------------------------------------------------------------------
> [INFO] BUILD SUCCESSFUL
> [INFO] ------------------------------------------------------------------------
> [INFO] Total time: 17 seconds
> [INFO] Finished at: Fri Feb 23 12:07:38 EST 2007
> [INFO] Final Memory: 22M/39M
> [INFO] ------------------------------------------------------------------------
> {noformat}
> If this pops up as an easy to fix Jason then great.  If there is a deeper problem that
requires debugging I'll be happy to do that.   I worked around this problem by explicitly
including the dependency in the client-transaction pom.xml. 
> This may be a config thing but its not obvious to me where this is broken then.
> Thanks

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message