geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rakesh Midha (JIRA)" <j...@apache.org>
Subject [jira] Commented: (GERONIMO-2742) Deployer cannot access libaries in shared/lib and shared/classes
Date Wed, 21 Feb 2007 13:13:05 GMT

    [ https://issues.apache.org/jira/browse/GERONIMO-2742?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_12474693
] 

Rakesh Midha commented on GERONIMO-2742:
----------------------------------------


Hello Aman

>From what I know and from the simple test I did on repository. I don't think there is
any problem in having directory named geronimo-connector-1.2-beta.jar (the name same as jar
file), I think you need to add META-INF and manifest.mf files in directory . This directory
will be treadted in same way as if it is a jar file.

This directory could be a symb link as you said, thought never tried this but i don't see
any problem in it.

Have you tried doing this, I think you should not face any problem with this.

thanks
Rakesh


> Deployer cannot access libaries in shared/lib and shared/classes
> ----------------------------------------------------------------
>
>                 Key: GERONIMO-2742
>                 URL: https://issues.apache.org/jira/browse/GERONIMO-2742
>             Project: Geronimo
>          Issue Type: Bug
>      Security Level: public(Regular issues) 
>          Components: deployment
>    Affects Versions: 1.2
>         Environment: Windows XP, Geronimo 1.2-beta
>            Reporter: Aman Nanner
>         Attachments: sharedlib-2.0.zip, sharedlib.zip, testing.ear.zip
>
>
> It seems that when running the deployer to deploy my EAR file, the classloaders during
deployment cannot access the shared/lib and shared/classes directory.  My app has dependencies
on libraries that are stored in both shared/classes and shared/lib.  Because these libraries
cannot be found, the deployment fails.
> Neither regular deployment nor hot deployment works.  My EAR file used to hot deploy
properly in Geronimo 1.1.1 (I never used the regular deployer in 1.1.1, so I don't know if
that would have worked too).

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message