geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Lin Sun (JIRA)" <j...@apache.org>
Subject [jira] Updated: (GERONIMO-2894) Restructure geronimo-axis2 code to split between EJB and POJO containers
Date Wed, 28 Feb 2007 17:39:56 GMT

     [ https://issues.apache.org/jira/browse/GERONIMO-2894?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Lin Sun updated GERONIMO-2894:
------------------------------

    Attachment: G2894-latest.patch

Hi Lasantha,

Thanks so much for reviewing the patch and notifying me of the build error.   This is the
first time I submit a patch to delete some files.   The patch would delete everything in the
files but it didn't get rid of the files.  So you got three 0KB files in your src\main\java\org\apache\geronimo\axis2
dir which causes the compile error.  I don't know if committing them would delete them in
the repo as I don't have committer's access to practice that.

Instead of using Tortoise SVN, I used svn diff this time to generate the above patch (G2894-latest.patch).
 What is nice about svn diff is that it can handle adding new files fine.   Please use this
latest patch instead.

Then I tried to apply the patch to a fresh checkout geronimo dir.  After applying the patch,
I still got the three 0KB java files (Axis2WebServiceContext.java
, EJBWebServiceGBean.java
, Axis2WebServiceContainerFactoryGBean.java) in the src\main\java\org\apache\geronimo\axis2
dir.  Then I deleted these 3 files manually  and I was able to run a full build after that.

> Restructure geronimo-axis2 code to split between EJB and POJO containers
> ------------------------------------------------------------------------
>
>                 Key: GERONIMO-2894
>                 URL: https://issues.apache.org/jira/browse/GERONIMO-2894
>             Project: Geronimo
>          Issue Type: Improvement
>      Security Level: public(Regular issues) 
>          Components: webservices
>         Environment: winxp + sun 1.5
>            Reporter: Lin Sun
>         Attachments: G2894-latest.patch, G2894-new.zip, G2894.patch
>
>
> This is needed as certain methods are POJO container specific, per Jarek's comment in
G2876.   
> Also attempted to fix the ?wsdl call in EJB mode by stripping the extra forward slash.
  ?wsdl still not working yet.  current exception is a Nullpointerexception returned from
uri.getQuery().   This is with jetty.    Need to track this one down next.
> Checked the POJO mode and jetty was able to return wsdl as the result of uri.getQuery().
> Tested the above change with all the tests (handlertest, axis2webservicecontainertest,
jax-ws-war and jax-ws-ejb) and also able to do a full build with the patch.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message