geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Lin Sun" <linsun....@gmail.com>
Subject RE: any chance our axis2 repo doesn't have the right jars?
Date Thu, 01 Feb 2007 18:26:27 GMT
The new jars look all right.  Thanks Dims!

Lin

-----Original Message-----
From: Davanum Srinivas [mailto:davanum@gmail.com] 
Sent: Thursday, February 01, 2007 12:45 PM
To: dev@geronimo.apache.org
Subject: Re: any chance our axis2 repo doesn't have the right jars?

There was a svn lock and i had to clean it up this morning. Can you
please check if these jars are ok?

http://ws.zones.apache.org/repository/org.apache.axis2/jars/

thanks,
dims

On 2/1/07, Lin Sun <linsun.unc@gmail.com> wrote:
> Hi Dims, I am trying to debug the prob where the deployer cannot start the
> jax-ws test module.   I am getting some NPE during deployment and the NPE
> appears to come from below:
>
> Caused by: java.lang.NullPointerException
>         at
> org.apache.axis2.jaxws.description.impl.ServiceDescriptionImpl.setupW
> sdlDefinition(ServiceDescriptionImpl.java:442)
>
> However, when I attach a debugger to the server and step over the code, it
> was not stepping through the right version of ServiceDescriptionImpl.java
> file, as it is running/doing stuff at comment lines or empty lines.   The
> debugger is using the latest axis2 trunk code, but I didn't build axis2
> myself (currently having trouble w/ that) and got the jars from the repo
> specified in Geronimo-axis2\pom.xml.   This file is inside of
> axis2-metadata-SNAPSHOT.jar, which I downloaded from the repo yesterday pm
> when I built Geronimo and has a timestamp of 1/31 pm.   Any chance we may
> not have the latest axis2 jar files (specifically
> axis2-metadata-SNAPSHOT.jar) in our axis2 repo?
>
> Thanks, Lin
>
>


-- 
Davanum Srinivas :: http://wso2.org/ :: Oxygen for Web Services Developers


Mime
View raw message