geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jason Dillon <ja...@planet57.com>
Subject Re: More than one version of stax:stax-api in dependencyManagement ?!
Date Fri, 12 Jan 2007 14:57:27 GMT
This is done, we are using 1.0.1 in trunk now.

--jason


On Jan 12, 2007, at 12:07 AM, David Jencks wrote:

> we definitely want stax-api 1.0.1, it fixes big bugs.
>
> It used to be that the xmlbeans 2.0 pom included the unavailable  
> jsr-173-api jar which required the exclusion.  However the  
> guaranteed immutable released poms seem to have changed and no  
> longer include this error so the exclusion may no longer be needed.
>
> thanks
> david jencks
>
> On Jan 11, 2007, at 1:11 PM, Davanum Srinivas wrote:
>
>> Axis2 needs 1.0.1. Can we please use that?
>>
>> thanks,
>> dims
>>
>> On 1/11/07, Jason Dillon <jason@planet57.com> wrote:
>>> I've found both of these:
>>>
>>>              <dependency>
>>>                  <groupId>stax</groupId>
>>>                  <artifactId>stax-api</artifactId>
>>>                  <version>1.0.1</version>
>>>              </dependency>
>>>
>>>              <dependency>
>>>                  <groupId>stax</groupId>
>>>                  <artifactId>stax-api</artifactId>
>>>                  <version>1.0</version>
>>>                  <exclusions>
>>>                      <exclusion>
>>>                          <groupId>xmlbeans</groupId>
>>>                          <artifactId>xmlbeans-jsr173-api</ 
>>> artifactId>
>>>                      </exclusion>
>>>                  </exclusions>
>>>              </dependency>
>>>
>>> Please pay more attention to what artifacts are already configured
>>> when you add/update dependencyManagement.
>>>
>>> --jason
>>>
>>
>>
>> -- 
>> Davanum Srinivas : http://www.wso2.net (Oxygen for Web Service  
>> Developers)
>


Mime
View raw message