geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jason Dillon <ja...@planet57.com>
Subject Re: Use JTA 1.1?
Date Fri, 12 Jan 2007 18:55:31 GMT
On Jan 12, 2007, at 1:44 PM, David Jencks wrote:
>>> We don't anymore, but we did/do for 1.2.x as we can't certify on  
>>> J2EE 1.4 with the jta 1.1 library in the path.
>>
>> Okay, I think we should merge geronimo-transaction-jta11 into  
>> geronimo-transaction-jta for server/trunk then.
>
> OK
> The original motivation was to reuse the 1.0.1 code in the 1.1 tm  
> without 2 copies of the code.  In the 2.0 work this is no longer  
> necessary.
>
> This may mean that 2.0 won't expose a 1.0.1 compatible tm, forcing  
> e.g. jencks to go to 1.1.  I doubt this would be a problem.

IMO, unless we really need to, we should not attempt to support  
legacy versions... its too much work and will add unneeded complexity.

--jason



Mime
View raw message