geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sachin Patel <sppat...@gmail.com>
Subject Re: Eclipse Plug-in plans for 2.0?
Date Tue, 23 Jan 2007 16:03:39 GMT
Yes, my current thinking is we need to continue providing support for  
previous versions of Geronimo in WTP 2.0, so thus the support code  
will need to continue to reside in trunk.  However, the support in  
for each version of G, should be broken down into multiple features,  
so that support for a given level of Geronimo can be installed  
independently.  This provides the most flexibility to our users.   
User A, only interested in G2.0 can install support for it without  
being forced to pull in support for previous levels.  And for those  
who don't want 2.0 support but want to have only 1.x support and want  
to run on WTP 2.0 will have this capability as well.

On Jan 23, 2007, at 10:41 AM, Donald Woods wrote:

> Will we continue to support prior server levels with the 2.0.0  
> Eclipse Plug-in, or will the new plug-in only support JEE 5 2.x  
> servers?
>
> Seems like a good time to split the plug-in and say - use the 1.2.x  
> plug-in for Geronimo 1.x and use the 2.x plug-in for Geronimo 2.x.....
>
>
> -Donald
>


-sachin



Mime
View raw message