geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Hernan Cunico <>
Subject Re: ApacheDS - LDAP - Geronimo Plugins
Date Fri, 12 Jan 2007 16:30:43 GMT
Paul McMahan wrote:
> OK now that I'm looking deeper into this things are becoming clearer.
> First of all, as you pointed out the directory module is already
> included in the jee5 assembly, which I wasn't aware of.  Apparently
> the commit that was supposed to have removed it from the dist only
> updated the config.xml and not the pom, which seems to have left it in
> the repo even though it's not listed in the server configuration.  Or
> maybe just removing it from the config.xml was sufficient to prune it
> from the dist before we started building with m2(?).   So at any rate,
> its in the assembly now just not listed in config.xml or started by
> default.

right, so we should decide whether we ship it as a plugin or in the assembly (properly configured
and enabled). If we go with the plugin idea then we should remove the mod and conf and any
other traces from the branch (not just the assembly). If we go the other way around maybe
we should remove the plugin for 1.2 and 2.0 as an alternative trying to avoid confusion. 

Either way, although important, I think now that is less critical as the plugin configuration
(Geronimo side) is working.

Personal preference, I would live it in the build till we refine the plugin architecture.

> And I think you've already sniffed out the reason why the directory
> plugin was marked as being available for install.  The version of the
> plugin in the catalog was 2.0-M1-SNAPSHOT but in the repo it was
> 2.0-SNAPSHOT.  I've adjusted the catalog now so that it works with

yup, it worked like a charm ;-)  thx


> trunk.  Please give it another try.  The plugin schema really needs
> some work so that versioning is easier to handle.
> Best wishes,
> Paul
> On 1/11/07, Hernan Cunico <> wrote:
>> Paul McMahan wrote:
>> > On 1/11/07, Hernan Cunico <> wrote:
>> >> Howdy,
>> >> ...
>> >> download/install as a plugin.
>> >
>> > As far as I can tell the directory module was never removed from the
>> > build.  It just got removed from the list of components that are
>> > enabled in the tomcat and jetty assemblies.  See rev 412604.  A
>> Time out! If I'm a user that only cares about the binary dist there is 
>> no way for me to know that, am I right!?
>> Either way, the service is already there in the assembly, it is just 
>> not starting by default.
>> > geronimo-plugin.xml file was also added to the directory module at
>> > that time so that it could be exported as a plugin and offered from a
>> > plugin repository.  But it doesn't have to be installed as a plugin,
>> > you could reenable it in the assemblies just as well.  Same for the
>> > other modules that used to be enabled in the assemblies by default
>> > such as servlet and jsp samples, etc.
>> This might be related to the issue you are seeing. At first I tried to 
>> export the already available directory service but it was not listed 
>> for export in the modules pull-down menu from the plugin portlet.
>> >
>> >> So the question is what do we want to do with it, offer LDAP as part
>> >> of the dist or separate as a plugin?
>> >
>> > Do you mean should it be reenabled in the default assemblies?
>> It is already there, in the assemblies for 1.2 and trunk. I'm 
>> personally happy to have it there and not having to install it as a 
>> plugin every time.
>> Checking at the pom.xml in the assemblies directory for Tomcat and and 
>> Jetty you can see
>>         <dependency>
>>             <groupId>org.apache.geronimo.configs</groupId>
>>             <artifactId>directory</artifactId>
>>             <version>${version}</version>
>>             <type>car</type>
>>         </dependency>
>>         <dependency>
>>             <groupId>org.apache.geronimo.configs</groupId>
>>             <artifactId>ldap-realm</artifactId>
>>             <version>${version}</version>
>>             <type>car</type>
>>         </dependency>
>> > Strictly speaking its not required for JEE5 and if someone needs it
>> Agreed, not required for JEE 5 but again, and personal view, nice to 
>> have ;-)
>> > then its pretty easy to install as a plugin from the Geronimo plugin
>> > repository at  Actually,
>> > installing it as a plugin in this way is equivalent to reenabling it
>> > in the assembly since that repository's catalog just points to the
>> > maven repo where Geronimo's artifacts are published.  The plugin
>> > approach just lets the user decide what Geronimo artifacts get enabled
>> > in the assembly instead of the person that typed "mvn"  :-)
>> >
>> >> Another question is, if I already see it available in the build (fresh
>> >> from trunk) why it still shows up as available for install in the
>> >> Install Plugin portlet?
>> >> (it will fail to install since the destination already exist)
>> >
>> > There might be an error in the plugin catalog.  If the module-id
>> > that's listed in the catalog matches the module-id for a component
>> yeah, I just realized the moduleId in the catalog is 
>> org.apache.geronimo.configs/directory/2.0-M1-SNAPSHOT/car and the one 
>> already in the assembly is 
>> org.apache.geronimo.configs/directory/2.0-SNAPSHOT/car
>> > that's already deployed in the server then it should not show us as
>> > available.  Actually I wasn't able to install the plugin for a
>> > different reason -- the 2.0-M1 configs published in the snapshot repo
>> > aren't compatible with 2.0 any more.  Are you sure that's not related
>> > to the error you're seeing?  If so then that should be fixed when we
>> > republish the configs (hopefully later today).
>> It could be a combination of the two errors, however it did fail the 
>> first time (installing the plugin over the assembly with the service 
>> already there) complaining the destination already existed. Haven't 
>> re-tested it yet.
>> I'll give it a shot again later today.
>> Cheers!
>> Hernan
>> >
>> > Best wishes,
>> > Paul
>> >

View raw message