geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Lin Sun (JIRA)" <j...@apache.org>
Subject [jira] Created: (GERONIMO-2724) create axis2 config and axis2-deployer config folders
Date Thu, 11 Jan 2007 18:30:28 GMT
create axis2 config and axis2-deployer config folders
-----------------------------------------------------

                 Key: GERONIMO-2724
                 URL: https://issues.apache.org/jira/browse/GERONIMO-2724
             Project: Geronimo
          Issue Type: New Feature
      Security Level: public (Regular issues)
          Components: webservices
    Affects Versions: 2.0
         Environment: Winxp + sun 1.5 JDK
            Reporter: Lin Sun


This is a patch on top of G2717 to create axis2 config and axis2-deployer config based on
the two cxf config modules.   I also enabled the modules\pom.xml + configs\pom.xml to include
the two axis2 modules and two axis2 configs.  I tried to remove some unnecessary dependencies
in modules\geronimo-axis2\pom.xml to keep it as simple as possible.

This built fine on my machine (patch created against revision 494904).   After a successful
build, I tried to turn on the axis2-deployer module in config.xml in jetty-jee5 assembly,
but the axis2-deployer module failed to start.  Here's the stack trace:

[*****************-          ] 60%  24s Startup failed
org.apache.geronimo.kernel.config.LifecycleException: load of org.apache.geronim
o.configs/axis2-deployer/2.0-SNAPSHOT/car failed
        at org.apache.geronimo.kernel.config.SimpleConfigurationManager.loadConf
iguration(SimpleConfigurationManager.java:271)
        at org.apache.geronimo.kernel.config.SimpleConfigurationManager.loadConf
iguration(SimpleConfigurationManager.java:250)
        at org.apache.geronimo.kernel.config.KernelConfigurationManager.loadConf
iguration(KernelConfigurationManager.java:112)
        at org.apache.geronimo.kernel.config.KernelConfigurationManager$$FastCla
ssByCGLIB$$b117102f.invoke(<generated>)
        at net.sf.cglib.reflect.FastMethod.invoke(FastMethod.java:53)
        at org.apache.geronimo.gbean.runtime.FastMethodInvoker.invoke(FastMethod
Invoker.java:38)
        at org.apache.geronimo.gbean.runtime.GBeanOperation.invoke(GBeanOperatio
n.java:127)
        at org.apache.geronimo.gbean.runtime.GBeanInstance.invoke(GBeanInstance.
java:820)
        at org.apache.geronimo.gbean.runtime.RawInvoker.invoke(RawInvoker.java:5
7)
        at org.apache.geronimo.kernel.basic.RawOperationInvoker.invoke(RawOperat
ionInvoker.java:35)
        at org.apache.geronimo.kernel.basic.ProxyMethodInterceptor.intercept(Pro
xyMethodInterceptor.java:96)
        at org.apache.geronimo.kernel.config.EditableConfigurationManager$$Enhan
cerByCGLIB$$854c5ac.loadConfiguration(<generated>)
        at org.apache.geronimo.system.main.Daemon.doStartup(Daemon.java:283)
        at org.apache.geronimo.system.main.Daemon.<init>(Daemon.java:74)
        at org.apache.geronimo.system.main.Daemon.main(Daemon.java:366)
Caused by: org.apache.geronimo.kernel.config.NoSuchConfigException: org.apache.g
eronimo.configs/axis2-deployer/2.0-SNAPSHOT/car
        at org.apache.geronimo.kernel.config.SimpleConfigurationManager.loadConf
igurationData(SimpleConfigurationManager.java:454)
        at org.apache.geronimo.kernel.config.SimpleConfigurationManager.loadConf
iguration(SimpleConfigurationManager.java:268)
        ... 14 more

Will look into that.  


 

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: https://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message