geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Jencks <david_jen...@yahoo.com>
Subject Re: windows build failure
Date Tue, 30 Jan 2007 16:38:53 GMT
Is stax-1.1.1 really required now for geronimo-service-builder?  This  
seems really really strange to me... can someone explain?

thanks
david jencks

On Jan 30, 2007, at 8:25 AM, Hernan Cunico wrote:

> Hi Tim,
> I tried with jdk1.5.0_06 through jdk1.5.0_10, no difference.
> I also tried moving the M2 repo all around but had the same results.
>
> I am not specifying any heap sz in JAVA_OPTS, instead I use this  
> specific for maven "MAVEN_OPTS=-Xmx512m -XX:MaxPermSize=128m - 
> Dmaven.test.skip=true". I don't think this diff could cause such a  
> consistent build failure. Either way I just tried that (switching  
> MVN and JAVA opts) and did not work.
>
> I also tried Kevan's suggestion of removing the specific version in  
> the root pom but with that I got a different build error. Actually  
> did not got that far in the build.
>
> Joe, is this the same error you saw on your machine?
>
> [INFO]  
> ---------------------------------------------------------------------- 
> --
> [ERROR] BUILD ERROR
> [INFO]  
> ---------------------------------------------------------------------- 
> --
> [INFO] Failed to resolve artifact.
>
> Missing:
> ----------
> 1) xmlbeans:xmlbeans-jsr173-api:jar:2.0-dev
>
>  Try downloading the file manually from the project website.
>
>  Then, install it using the command:
>      mvn install:install-file -DgroupId=xmlbeans - 
> DartifactId=xmlbeans-jsr173-api \
>          -Dversion=2.0-dev -Dpackaging=jar -Dfile=/path/to/file
>
>  Path to dependency:
>        1) org.apache.geronimo.modules:geronimo-service-builder:jar: 
> 2.0-SNAPSHOT
>        2) stax:stax:jar:1.1.1-dev
>        3) xmlbeans:xmlbeans-jsr173-api:jar:2.0-dev
>
> ----------
> 1 required artifact is missing.
>
> for artifact:
>  org.apache.geronimo.modules:geronimo-service-builder:jar:2.0-SNAPSHOT
>
> from the specified remote repositories:
>  central (http://repo1.maven.org/maven2),
>  apache.snapshots (http://people.apache.org/repo/m2-snapshot- 
> repository),
>  codehaus (http://repository.codehaus.org),
>  apache-snapshots (http://people.apache.org/repo/m2-snapshot- 
> repository),
>  codehaus-snapshots (http://snapshots.repository.codehaus.org),
>  apache-incubator (http://people.apache.org/repo/m2-incubating- 
> repository/),
>  tomcat-m2-repo (http://tomcat.apache.org/dev/dist/m2-repository/)
>
> Cheers!
> Hernan
>
>
> Tim McConnell wrote:
>> Hi Hernan, I just compared your output with mine (which is working  
>> for me on Windows) and only see a few subtle environment  
>> differences. Here are mine, but I doubt they'd change your results  
>> though:
>>     JAVA_HOME=C:\Program Files\Java\jdk1.5.0_07
>>     JAVA_OPTS=-Xms512m -Xmx512m
>>     M2_HOME=C:\Program Files\Apache Software Foundation\maven-2.0.4
>>     Hernan Cunico wrote:
>>> Just in case somebody is having the same prob I'm attaching "mvn  
>>> install -e -X >> output.txt 2>>&1"
>>>
>>> Cheers!
>>> Hernan
>>>
>>> Hernan Cunico wrote:
>>>> Enabling extensions did not work for me.
>>>>
>>>> Cheers!
>>>> Hernan
>>>>
>>>> Donald Woods wrote:
>>>>> If you're using WinXP or Win2003 without Cygwin or other shell  
>>>>> changes, try changing the following line in your <M2_HOME>\bin

>>>>> \mvn.bat -
>>>>>    if "%OS%"=="Windows_NT" @setlocal
>>>>> to:
>>>>>    if "%OS%"=="Windows_NT" @setlocal enableextensions
>>>>>
>>>>>
>>>>> -Donald
>>>>>
>>>>> Joe Bohn wrote:
>>>>>> No, I haven't attempted that yet.  I'll give that a try a  
>>>>>> little later.  Right now I'm trying to see if building  
>>>>>> OpenEJB3 locally makes any difference since I know of at least  
>>>>>> one person that isn't hitting this problem but has built  
>>>>>> openejb3.
>>>>>>
>>>>>> Thanks for the responses and ideas.
>>>>>>
>>>>>> Joe
>>>>>>
>>>>>>
>>>>>> anita kulshreshtha wrote:
>>>>>>>   Have you tried moving these 2 files to their rightful  
>>>>>>> place, i.e. in
>>>>>>> 3.0-incubating-SNAPSHOT directory?
>>>>>>>
>>>>>>> container-3.0-incubating-20070123.025044-17.pom
>>>>>>> container-3.0-incubating-20070123.025044-17.pom.sha1
>>>>>>>
>>>>>>> Thanks
>>>>>>> Anita
>>>>>>>
>>>>>>> --- Joe Bohn <joe.bohn@earthlink.net> wrote:
>>>>>>>
>>>>>>>> I think the problem that Hernan reported last week building
on
>>>>>>>> Windows is still alive and well.  It doesn't seem to cause
 
>>>>>>>> any problems on
>>>>>>>> OSX.
>>>>>>>>
>>>>>>>> I was hitting it yesterday and just hit it again today with
the
>>>>>>>> 2.0-M2 branch, rev. 499407.
>>>>>>>>
>>>>>>>>
>>>>>>>> It seems to me that there is something fishy with the  
>>>>>>>> container-3.0-incubating-SNAPSHOT.pom that only seems to
 
>>>>>>>> cause grief
>>>>>>>> on windows (see the messages below between the "*******"
 
>>>>>>>> lines I
>>>>>>>> inserted where there is an error reading and error in  
>>>>>>>> opening the zip file).
>>>>>>>>
>>>>>>>>
>>>>>>>> This results in some strange entries in my local repo for
 
>>>>>>>> the openejb
>>>>>>>>
>>>>>>>> container:
>>>>>>>>
>>>>>>>> +---3.0-incubating-20070123.025044-17
>>>>>>>> |       container-3.0-incubating-20070123.025044-17.pom
>>>>>>>> |       container-3.0-incubating-20070123.025044-17.pom.sha1
>>>>>>>> |
>>>>>>>> \---3.0-incubating-SNAPSHOT
>>>>>>>>          container-3.0-incubating-SNAPSHOT.pom
>>>>>>>>
>>>>>>>>
>>>>>>>> Deleting these time-stamp entries and running again doesn't
 
>>>>>>>> seem to avoid the problem.   This is building with a  
>>>>>>>> completely empty repo
>>>>>>>> and clean %tmp% with a fresh checkout.   I've recreated on
2  
>>>>>>>> different machines.   I think something is screwed up with
 
>>>>>>>> the pom or maven-metadata but I'm not up on maven enough
to  
>>>>>>>> know what it is.
>>>>>>>>
>>>>>>>>
>>>>>>>>
>>>>>>>>
>>>>>>>> [INFO]
>>>>>>> ----------------------------------------------------------------

>>>>>>> ------------
>>>>>>>> [INFO] Building Geronimo :: OpenEJB :: Builder
>>>>>>>> [INFO]    task-segment: [clean, install]
>>>>>>>> [INFO]
>>>>>>> ----------------------------------------------------------------

>>>>>>> ------------
>>>>>>>> [INFO] [clean:clean]
>>>>>>>> [INFO] Deleting directory C:\geronimo2.0-M2\modules\geronimo-

>>>>>>>> openejb-builder\target
>>>>>>>> [INFO] Deleting directory C:\geronimo2.0-M2\modules\geronimo-

>>>>>>>> openejb-builder\target\classes
>>>>>>>> [INFO] Deleting directory
>>>>>>> C:\geronimo2.0-M2\modules\geronimo-openejb-builder\target 
>>>>>>> \test-classes
>>>>>>>> [INFO] [tools:require-java-version {execution:
>>>>>>>> validate-java-version}]
>>>>>>>> Downloading:
>>>>>>> http://tomcat.apache.org/dev/dist/m2-repository//org/apache/

>>>>>>> geronimo/specs/geronimo-ejb_3.0_spec/1.0-M1/geronimo- 
>>>>>>> ejb_3.0_spec-1.0-M1.jar
>>>>>>>> [WARNING] Unable to get resource from repository tomcat-m2-

>>>>>>>> repo (http://tomcat.apache.org/dev/dist/m2-repository/)
>>>>>>>> Downloading:
>>>>>>> http://people.apache.org/repo/m2-incubating-repository//org/

>>>>>>> apache/geronimo/specs/geronimo-ejb_3.0_spec/1.0-M1/geronimo-

>>>>>>> ejb_3.0_spec-1.0-M1.jar
>>>>>>>> [WARNING] Unable to get resource from repository apache-

>>>>>>>> incubator (http://people.apache.org/repo/m2-incubating- 
>>>>>>>> repository/)
>>>>>>>> Downloading:
>>>>>>> http://repository.codehaus.org/org/apache/geronimo/specs/ 
>>>>>>> geronimo-ejb_3.0_spec/1.0-M1/geronimo-ejb_3.0_spec-1.0-M1.jar
>>>>>>>> [WARNING] Unable to get resource from repository codehaus
 
>>>>>>>> (http://repository.codehaus.org)
>>>>>>>> Downloading:
>>>>>>> http://people.apache.org/repo/m2-incubating-repository/org/ 
>>>>>>> apache/geronimo/specs/geronimo-ejb_3.0_spec/1.0-M1/geronimo-

>>>>>>> ejb_3.0_spec-1.0-M1.jar
>>>>>>>> [WARNING] Unable to get resource from repository apache-

>>>>>>>> incubating-repository (http://people.apache.org/repo/m2-

>>>>>>>> incubating-repository)
>>>>>>>> Downloading:
>>>>>>> http://repo1.maven.org/maven2/org/apache/geronimo/specs/ 
>>>>>>> geronimo-ejb_3.0_spec/1.0-M1/geronimo-ejb_3.0_spec-1.0-M1.jar
>>>>>>>> 31K downloaded
>>>>>>>> [INFO] [xmlbeans:xmlbeans {execution: default}]
>>>>>>>> Time to build schema type system: 0.156 seconds
>>>>>>>> Time to generate code: 0.125 seconds
>>>>>>>>
>>>>>>>> *******
>>>>>>>>
>>>>>>>> error: error reading
>>>>>>> c:\m2repo\org\apache\openejb\container\3.0-incubating-SNAPSHOT

>>>>>>> \container-3.0-incubating-SNAPSHOT.pom;
>>>>>>>> error in opening zip file
>>>>>>>> Note: Some input files use or override a deprecated API.
>>>>>>>> Note: Recompile with -Xlint:deprecation for details.
>>>>>>>> 1 error
>>>>>>>>
>>>>>>>> *******
>>>>>>>>
>>>>>>>>
>>>>>>>> BUILD FAILED
>>>>>>>> [INFO]
>>>>>>> ----------------------------------------------------------------

>>>>>>> --------
>>>>>>>> [ERROR] BUILD ERROR
>>>>>>>> [INFO]
>>>>>>> ----------------------------------------------------------------

>>>>>>> --------
>>>>>>>> [INFO] XmlBeans compile failed:
>>>>>>>>   xml ErrorLoading schema file
>>>>>>> C:\geronimo2.0-M2\modules\geronimo-openejb-builder\src\main 
>>>>>>> \schema\geronimo-openejb-2.0.xsd
>>>>>>>> xml ErrorLoading config file
>>>>>>> C:\geronimo2.0-M2\modules\geronimo-openejb-builder\src\main 
>>>>>>> \schema\xmlconfig.xml
>>>>>>>> [INFO]
>>>>>>> ----------------------------------------------------------------

>>>>>>> --------
>>>>>>>> [INFO] For more information, run Maven with the -e switch
>>>>>>>> [INFO]
>>>>>>> ----------------------------------------------------------------

>>>>>>> --------
>>>>>>>> [INFO] Total time: 12 minutes 20 seconds
>>>>>>>> [INFO] Finished at: Wed Jan 24 09:26:39 EST 2007
>>>>>>>> [INFO] Final Memory: 62M/116M
>>>>>>>> [INFO]
>>>>>>> ----------------------------------------------------------------

>>>>>>> --------
>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>>   
>>>>>>> ________________________________________________________________

>>>>>>> ____________________
>>>>>>> Don't get soaked.  Take a quick peak at the forecast
>>>>>>> with the Yahoo! Search weather shortcut.
>>>>>>> http://tools.search.yahoo.com/shortcuts/#loc_weather
>>>>>>>
>>>>>>
>>>>>>
>>>>


Mime
View raw message