geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Prasad Kashyap" <goyathlay.geron...@gmail.com>
Subject Re: G2.0 and OpenEJB 2.2 relation broken.
Date Mon, 11 Dec 2006 19:36:43 GMT
Yes. I have been able to build Geronimo-2.0-SNAPSHOT  on a clean repo
without pulling in anything from 1.2 (except
tranql-connector-derby-common).

However, when I build Openejb-2.2, it pulls in all Geronimo-1.2 artifacts.

Next, the openjeb-itests-core.jar  now fails to install on
Geronimo-2.0-SNAPSHOT b'coz it has a dependency on 1.2 too.

Cheers
Prasad

On 12/11/06, David Blevins <david.blevins@visi.com> wrote:
> On Dec 11, 2006, at 10:51 AM, Prasad Kashyap wrote:
>
> > Geronimo 2.0-SNAPSHOT pulls in OpenEJB-2.2
> > OpenEJB-2.2 has a dependency on Geronimo-1.2-SNAPSHOT
>
> All org.apache.geronimo.* deps in OpenEJB were marked as non-
> transitive.  It's been very heavily tested that you can build G 2.0-
> SNAPSHOT without pulling in any G 1.2-SNAPSHOTS at all.
>
> -David
>

Mime
View raw message