geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jason Dillon <ja...@planet57.com>
Subject specs/trunk/pom.xml is at version 1.2?
Date Sat, 16 Dec 2006 00:19:49 GMT
so, now we have reverted back to having bits under trunk/* using non- 
snapshot values?

and it appears that some modules (geronimo-commonj_1.1_spec at the  
least) still depend on 1.2-SNAPSHOT, which really screws things up  
when building in a clean environment.

trunk/pom.xml should be at version 1.3-SNAPSHOT, and all of the  
children modules should use that version for its parent.

this has quickly turned into a mess.... and I am now kinda screwed.   
all of the work I am doing is always off of a clean repo, so that I  
can avoid any slop that might be caused by previous builds.

i'm really not happy that I have to come in and clean up afterwards...

and I wish there was a little more trust that I actually knew what I  
was doing... after all I have been working on simplifying the build  
process, and helping to make it more stable and reliable.

anyways, I will try to find a solution to this... but the recent  
changes for the 1.2-beta release have really thrown a big wrench into  
the works relating to the fluff I was working on to automate the TCK  
and to provide direct correlation from code change to test results.

--jason

Mime
View raw message