geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From anita kulshreshtha <a_kuls...@yahoo.com>
Subject Re: Something is up with jee-specs config
Date Fri, 01 Dec 2006 14:03:48 GMT
  I had used maven's natural lexical sorting order and 'provided' scope
to make sure that the configs were built in the correct order. The
provided scope was ignored by the car plugin. What mechanism is used
now to enforce the build order?

Thanks
Anita

--- Jason Dillon <jason@planet57.com> wrote:

> I keep getting this on a clean build:
> 
> <snip>
> [INFO]  
>
------------------------------------------------------------------------
> [ERROR] BUILD ERROR
> [INFO]  
>
------------------------------------------------------------------------
> [INFO] Failed to resolve artifact.
> Missing:
> ----------
> 1)
> org.apache.geronimo.configs:geronimo-gbean-deployer:car:2.0-SNAPSHOT
>    Try downloading the file manually from the project website.
>    Then, install it using the command:
>        mvn install:install-file -DgroupId=org.apache.geronimo.configs
>  
> -DartifactId=geronimo-gbean-deployer \
>            -Dversion=2.0-SNAPSHOT -Dpackaging=car
> -Dfile=/path/to/file
>    Path to dependency:
>    	1) org.apache.geronimo.configs:jee-specs:car:2.0-SNAPSHOT
>    	2) org.apache.geronimo.configs:geronimo-gbean-deployer:car:2.0- 
> SNAPSHOT
> ----------
> 1 required artifact is missing.
> for artifact:
>    org.apache.geronimo.configs:jee-specs:car:2.0-SNAPSHOT
> from the specified remote repositories:
>    central (http://repo1.maven.org/maven2),
>    apache.snapshots (http://people.apache.org/repo/m2-snapshot- 
> repository),
>    codehaus (http://repository.codehaus.org),
>    apache-snapshots (http://people.apache.org/repo/m2-snapshot- 
> repository),
>    codehaus-snapshots (http://snapshots.repository.codehaus.org)
> [INFO]  
>
------------------------------------------------------------------------
> </snip>
> 
> Also, the name is a tad odd...  the module is "jee-specs", but the  
> name is "Geronimo Configs :: J2EE 1.4 specs", not what I would
> expect.
> 
> Neways, looks like a dependency mismatch of somekind... as "Geronimo 
> 
> Configs :: J2EE 1.4 specs" builds right after "Geronimo Configs" not 
> 
> giving the gbean deployer config a chance to be built yet.
> 
> :-(
> 
> --jason
> 



 
____________________________________________________________________________________
Cheap talk?
Check out Yahoo! Messenger's low PC-to-Phone call rates.
http://voice.yahoo.com

Mime
View raw message