geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jason Dillon <ja...@planet57.com>
Subject Re: How to build devtools/eclipse-plugin?
Date Thu, 07 Dec 2006 21:01:48 GMT
I think I'm gonna have to update this project's poms... repos need to  
be updated, rsync-repositories need to be removed, disto config needs  
to be normalized, etc.

What is needed from the legacy repos?  Using legacy repos tends to  
confuse m2 and generally I would recommend avoiding it where  
possible.  What is in maven1-sppatel?

I'm also a bit confused by the way that <modules> have been setup.   
For example, there is <module>modules/eclipse-support</module>,  
though there is no modules/pom.xml as I would have expected.  Same  
with maven-plugins.  Any reason for this?

Anyways, this is not building for me now with a bunch of missing  
artifacts, though my guess is that some of that is due to network  
issues possibly due to the use of the apache rsync repos as mvn repos  
(which is not what they are for).

<snip>
[INFO] Failed to resolve artifact.
Missing:
----------
1) org.eclipse.plugins:org.eclipse.jst.j2ee.web:jar:1.1.2.v200610182223
   Try downloading the file manually from the project website.
   Then, install it using the command:
       mvn install:install-file -DgroupId=org.eclipse.plugins - 
DartifactId=org.eclipse.jst.j2ee.web \
           -Dversion=1.1.2.v200610182223 -Dpackaging=jar -Dfile=/path/ 
to/file
   Path to dependency:
   	1) org.apache.geronimo.devtools:org.apache.geronimo.st.core:jar: 
1.1.0
   	2) org.eclipse.plugins:org.eclipse.jst.j2ee.web:jar: 
1.1.2.v200610182223
2) org.eclipse.plugins:org.eclipse.wst.common.project.facet.core:jar: 
1.0.1.v200605040144
   Try downloading the file manually from the project website.
   Then, install it using the command:
       mvn install:install-file -DgroupId=org.eclipse.plugins - 
DartifactId=org.eclipse.wst.common.project.facet.core \
           -Dversion=1.0.1.v200605040144 -Dpackaging=jar -Dfile=/path/ 
to/file
   Path to dependency:
   	1) org.apache.geronimo.devtools:org.apache.geronimo.st.core:jar: 
1.1.0
   	2)  
org.eclipse.plugins:org.eclipse.wst.common.project.facet.core:jar: 
1.0.1.v200605040144
3) org.eclipse.plugins:org.eclipse.jst.server.core:jar: 
1.0.1.v200605040115
   Try downloading the file manually from the project website.
   Then, install it using the command:
       mvn install:install-file -DgroupId=org.eclipse.plugins - 
DartifactId=org.eclipse.jst.server.core \
           -Dversion=1.0.1.v200605040115 -Dpackaging=jar -Dfile=/path/ 
to/file
   Path to dependency:
   	1) org.apache.geronimo.devtools:org.apache.geronimo.st.core:jar: 
1.1.0
   	2) org.eclipse.plugins:org.eclipse.jst.server.core:jar: 
1.0.1.v200605040115
4) org.eclipse.plugins:org.eclipse.emf.ecore:jar:2.2.0.v200609210005
   Try downloading the file manually from the project website.
   Then, install it using the command:
       mvn install:install-file -DgroupId=org.eclipse.plugins - 
DartifactId=org.eclipse.emf.ecore \
           -Dversion=2.2.0.v200609210005 -Dpackaging=jar -Dfile=/path/ 
to/file
   Path to dependency:
   	1) org.apache.geronimo.devtools:org.apache.geronimo.st.core:jar: 
1.1.0
   	2) org.eclipse.plugins:org.eclipse.emf.ecore:jar:2.2.0.v200609210005
5) org.eclipse.plugins:org.eclipse.jem.util:jar:1.2.1.v20060918_M
   Try downloading the file manually from the project website.
   Then, install it using the command:
       mvn install:install-file -DgroupId=org.eclipse.plugins - 
DartifactId=org.eclipse.jem.util \
           -Dversion=1.2.1.v20060918_M -Dpackaging=jar -Dfile=/path/ 
to/file
   Path to dependency:
   	1) org.apache.geronimo.devtools:org.apache.geronimo.st.core:jar: 
1.1.0
   	2) org.eclipse.plugins:org.eclipse.jem.util:jar:1.2.1.v20060918_M
6) org.eclipse.plugins:org.eclipse.jst.j2ee.jca:jar:1.1.2.v200610182223
   Try downloading the file manually from the project website.
   Then, install it using the command:
       mvn install:install-file -DgroupId=org.eclipse.plugins - 
DartifactId=org.eclipse.jst.j2ee.jca \
           -Dversion=1.1.2.v200610182223 -Dpackaging=jar -Dfile=/path/ 
to/file
   Path to dependency:
   	1) org.apache.geronimo.devtools:org.apache.geronimo.st.core:jar: 
1.1.0
   	2) org.eclipse.plugins:org.eclipse.jst.j2ee.jca:jar: 
1.1.2.v200610182223
7) org.eclipse.plugins:org.eclipse.jdt.core:jar:3.2.1.r321_v20060823
   Try downloading the file manually from the project website.
   Then, install it using the command:
       mvn install:install-file -DgroupId=org.eclipse.plugins - 
DartifactId=org.eclipse.jdt.core \
           -Dversion=3.2.1.r321_v20060823 -Dpackaging=jar -Dfile=/ 
path/to/file
   Path to dependency:
   	1) org.apache.geronimo.devtools:org.apache.geronimo.st.core:jar: 
1.1.0
   	2) org.eclipse.plugins:org.eclipse.jdt.core:jar:3.2.1.r321_v20060823
8) org.eclipse.plugins:org.eclipse.jst.common.project.facet.core:jar: 
1.0.1.v200605040115
   Try downloading the file manually from the project website.
   Then, install it using the command:
       mvn install:install-file -DgroupId=org.eclipse.plugins - 
DartifactId=org.eclipse.jst.common.project.facet.core \
           -Dversion=1.0.1.v200605040115 -Dpackaging=jar -Dfile=/path/ 
to/file
   Path to dependency:
   	1) org.apache.geronimo.devtools:org.apache.geronimo.st.core:jar: 
1.1.0
   	2)  
org.eclipse.plugins:org.eclipse.jst.common.project.facet.core:jar: 
1.0.1.v200605040115
9) org.eclipse.plugins:org.eclipse.emf.ecore.xmi:jar:2.2.0.v200609210005
   Try downloading the file manually from the project website.
   Then, install it using the command:
       mvn install:install-file -DgroupId=org.eclipse.plugins - 
DartifactId=org.eclipse.emf.ecore.xmi \
           -Dversion=2.2.0.v200609210005 -Dpackaging=jar -Dfile=/path/ 
to/file
   Path to dependency:
   	1) org.apache.geronimo.devtools:org.apache.geronimo.st.core:jar: 
1.1.0
   	2) org.eclipse.plugins:org.eclipse.emf.ecore.xmi:jar: 
2.2.0.v200609210005
10) org.eclipse.plugins:org.eclipse.emf.common:jar:2.2.0.v200609210005
   Try downloading the file manually from the project website.
   Then, install it using the command:
       mvn install:install-file -DgroupId=org.eclipse.plugins - 
DartifactId=org.eclipse.emf.common \
           -Dversion=2.2.0.v200609210005 -Dpackaging=jar -Dfile=/path/ 
to/file
   Path to dependency:
   	1) org.apache.geronimo.devtools:org.apache.geronimo.st.core:jar: 
1.1.0
   	2) org.eclipse.plugins:org.eclipse.emf.common:jar: 
2.2.0.v200609210005
11) org.eclipse.plugins:org.eclipse.wst.common.environment:jar: 
1.0.1.v200605040144
   Try downloading the file manually from the project website.
   Then, install it using the command:
       mvn install:install-file -DgroupId=org.eclipse.plugins - 
DartifactId=org.eclipse.wst.common.environment \
           -Dversion=1.0.1.v200605040144 -Dpackaging=jar -Dfile=/path/ 
to/file
   Path to dependency:
   	1) org.apache.geronimo.devtools:org.apache.geronimo.st.core:jar: 
1.1.0
   	2) org.eclipse.plugins:org.eclipse.wst.common.environment:jar: 
1.0.1.v200605040144
12) org.eclipse.plugins:org.eclipse.jst.j2ee.ejb:jar:1.1.2.v200610182223
   Try downloading the file manually from the project website.
   Then, install it using the command:
       mvn install:install-file -DgroupId=org.eclipse.plugins - 
DartifactId=org.eclipse.jst.j2ee.ejb \
           -Dversion=1.1.2.v200610182223 -Dpackaging=jar -Dfile=/path/ 
to/file
   Path to dependency:
   	1) org.apache.geronimo.devtools:org.apache.geronimo.st.core:jar: 
1.1.0
   	2) org.eclipse.plugins:org.eclipse.jst.j2ee.ejb:jar: 
1.1.2.v200610182223
13) org.eclipse.plugins:org.eclipse.wst.common.frameworks:jar: 
1.0.1.v200605040144
   Try downloading the file manually from the project website.
   Then, install it using the command:
       mvn install:install-file -DgroupId=org.eclipse.plugins - 
DartifactId=org.eclipse.wst.common.frameworks \
           -Dversion=1.0.1.v200605040144 -Dpackaging=jar -Dfile=/path/ 
to/file
   Path to dependency:
   	1) org.apache.geronimo.devtools:org.apache.geronimo.st.core:jar: 
1.1.0
   	2) org.eclipse.plugins:org.eclipse.wst.common.frameworks:jar: 
1.0.1.v200605040144
----------
13 required artifacts are missing.
for artifact:
   org.apache.geronimo.devtools:org.apache.geronimo.st.core:jar:1.1.0
from the specified remote repositories:
   maven1-apache (http://people.apache.org/repository),
   central (http://repo1.maven.org/maven2),
   maven2-snapshot-apache (http://people.apache.org/maven-snapshot- 
repository),
   maven1-sppatel (http://people.apache.org/~sppatel/repository),
   maven1-codehaus (http://dist.codehaus.org/),
   maven2-snapshot-codehaus (http://snapshots.maven.codehaus.org/ 
maven2),
   maven1-ibiblio (http://people.apache.org/repo/m1-ibiblio-rsync- 
repository/),
   maven2-ibiblio (http://people.apache.org/repo/m2-ibiblio-rsync- 
repository)
</snip>

  * * *

I'm probably not going to get time to do this right now, but I can  
normalize this project and hook it up for build automation a little  
later.

--jason


On Dec 7, 2006, at 5:40 AM, Sachin Patel wrote:

> That would be really good if you could do that.  A mvn install at  
> the root will pull down everything you need and generate the  
> assemblies.
>
> On Dec 6, 2006, at 6:31 PM, Jason Dillon wrote:
>
>> Is there any special requirements to build this puppy?  Does  
>> Eclipse need to be installed or something?
>>
>> I'm asking first... have not actually tried yet... but would like  
>> to hook this up to automatically build if possible.
>>
>> --jason
>
>
> -sachin
>
>


Mime
View raw message