geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Prasad Kashyap" <goyathlay.geron...@gmail.com>
Subject Re: 1.2 Branch is cut
Date Sun, 19 Nov 2006 22:15:27 GMT
OK. To execute 'mvn' from geronimo/testsuite, it requires 1.5
(tools-require plugin). So you set your JAVA_HOME to point to jdk1.5.

Then during the testsuite run, it installs the server and tries to
start it (geronimo-maven-plugin:startServer). But the server binary is
still jdk 1.4. And here it tries to run on jdk 1.5. So it fails.

Running the server separately with JAVA_HOME pointing to jdk1.4 works
fine. So that is a workaround.

Cheers
Prasad

On 11/19/06, Jason Dillon <jason@planet57.com> wrote:
> While I agree we should move to 1.5 for the entire tree... I don't
> get what you think is broken... you can make the testsuite use
> 1.5/1.5 and it should work fine.
>
> --jason
>
>
> On Nov 19, 2006, at 10:13 AM, Prasad Kashyap wrote:
>
> > Let's move to building the trunk's  soure and target with 1.5 quickly
> > please. The testsuite is broken because the 'mvn' execution needs a
> > 1.5 but the server it starts within it needs a 1.4 jdk.
> >
> > The workaround is to first start the server using 1.4 and then run
> > testsuite using 1.5.
> >
> > Cheers
> > Prasad
> >
> > On 11/18/06, Jason Dillon <jason@planet57.com> wrote:
> >> Yes, lets do this for 2.0-SNAPSHOT
> >>
> >> --jason
> >>
> >>
> >> On Nov 18, 2006, at 2:52 PM, Matt Hogstrom wrote:
> >>
> >> >
> >> > On Nov 18, 2006, at 10:11 AM, anita kulshreshtha wrote:
> >> >
> >> >>   Are we going to use 1.5 compiler?
> >> >>
> >> > We are using it now for trunk I thought.  I'd like to make it all
> >> > 1.5 in terms of generated classes, etc.  Thoughts.
> >>
> >>
>
>

Mime
View raw message