geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jason Dillon <ja...@planet57.com>
Subject Something is up with jee-specs config
Date Fri, 01 Dec 2006 05:13:46 GMT
I keep getting this on a clean build:

<snip>
[INFO]  
------------------------------------------------------------------------
[ERROR] BUILD ERROR
[INFO]  
------------------------------------------------------------------------
[INFO] Failed to resolve artifact.
Missing:
----------
1) org.apache.geronimo.configs:geronimo-gbean-deployer:car:2.0-SNAPSHOT
   Try downloading the file manually from the project website.
   Then, install it using the command:
       mvn install:install-file -DgroupId=org.apache.geronimo.configs  
-DartifactId=geronimo-gbean-deployer \
           -Dversion=2.0-SNAPSHOT -Dpackaging=car -Dfile=/path/to/file
   Path to dependency:
   	1) org.apache.geronimo.configs:jee-specs:car:2.0-SNAPSHOT
   	2) org.apache.geronimo.configs:geronimo-gbean-deployer:car:2.0- 
SNAPSHOT
----------
1 required artifact is missing.
for artifact:
   org.apache.geronimo.configs:jee-specs:car:2.0-SNAPSHOT
from the specified remote repositories:
   central (http://repo1.maven.org/maven2),
   apache.snapshots (http://people.apache.org/repo/m2-snapshot- 
repository),
   codehaus (http://repository.codehaus.org),
   apache-snapshots (http://people.apache.org/repo/m2-snapshot- 
repository),
   codehaus-snapshots (http://snapshots.repository.codehaus.org)
[INFO]  
------------------------------------------------------------------------
</snip>

Also, the name is a tad odd...  the module is "jee-specs", but the  
name is "Geronimo Configs :: J2EE 1.4 specs", not what I would expect.

Neways, looks like a dependency mismatch of somekind... as "Geronimo  
Configs :: J2EE 1.4 specs" builds right after "Geronimo Configs" not  
giving the gbean deployer config a chance to be built yet.

:-(

--jason

Mime
View raw message