geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Jencks <david_jen...@yahoo.com>
Subject Re: deployer offline mode on 1.2 branch?
Date Wed, 22 Nov 2006 17:23:24 GMT

On Nov 22, 2006, at 9:07 AM, toby cabot wrote:

> Hi Folks,
>
> I'd like to use the 1.2 deployer's offline mode (and hopefully the
> distribute command) but it's not working out-of-the-box at the moment.
> Is it supposed to, or is it a non-feature?  I could get it to work by
> running it like so:
>
> $ java -Djava.ext.dirs=/tmp/g/repository/stax/stax-api/1.0:/tmp/g/ 
> repository/xmlbeans/xbean/2.0.0 -jar /tmp/g/bin/deployer.jar -- 
> offline list-modules
>
> ... otherwise it can't find org/apache/xmlbeans/XmlObject and
> javax/xml/stream/XMLStreamException.  If this is supposed to work then
> I'd imagine that we'd want to add these jars to the deployer's jar
> manifest classpath.  I can take a look at doing this if someone could
> point me to the part of the build process that jars deployer.jar.

I'm not surprised that it doesn't work but I am very surprised your  
fix worked :-)

I thought the problem would be that the files var/config/offline- 
deployer-list didn't have all the new deployer configs we came up  
with in them.

Can you investigate whether the xmlbeans stuff got into the classpath  
through manifest classpath entries in 1.1 which I think is the last  
time offline deployment was tested?

thanks
david jencks

>
> Thanks,
> Toby


Mime
View raw message