geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Jencks <david_jen...@yahoo.com>
Subject Re: Can anyone build 1.2?
Date Wed, 22 Nov 2006 17:28:25 GMT
I think the answer is "not if you've built 2.0"

I traced through uddi-jetty and even after your transitive-deps fix  
for explicit_versions.properties I'm still seeing a lot of 2.0  
artifacts loaded into the g. kernel.

I think a solution might be to make the car plugin run off a  
"repository view" or "virtual repository" that only lets it see the  
transitive closure of the dependencies mentioned in the car file.

I'll see if I can  get this to work...

thanks
david jencks

On Nov 21, 2006, at 4:40 PM, Jason Dillon wrote:

> I keep running into car problems, like:
>
> <snip>
> [INFO] Packaging module configuration: /Users/jason/ws/geronimo/ 
> server-1.2/configs/system-database/target/plan/plan.xml
> [INFO]  
> ---------------------------------------------------------------------- 
> --
> [ERROR] BUILD ERROR
> [INFO]  
> ---------------------------------------------------------------------- 
> --
> [INFO] load of org.apache.geronimo.configs/j2ee-deployer/1.2- 
> SNAPSHOT/car failed
>
> Configuration gbean failed to start org.apache.geronimo.configs/ 
> j2ee-deployer/1.2-SNAPSHOT/car
> </snip>
>
> How useful is that error message... um... not very useful at all.
>
> After building openejb2 by hand, trunk appears to build fine... but  
> I can't get 1.2 to build.
>
> Has anyone gotten 1.2 to build since the branch was made?
>
> --jason


Mime
View raw message