geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Matt Hogstrom <m...@hogstrom.org>
Subject Updates to OEJB 2.2 and TranQL 1.4
Date Mon, 13 Nov 2006 23:55:01 GMT
I have updated TranQL 1.4 and Open EJB 2.2 to support specification  
of a Select-For-Update clause in the openejb-jar.xsd when deploying  
CMP EJBs.  I have published new SNAPSHOTs of both projects so in a  
perfect world there should be no pain :)

I'll be stress testing DayTrader tonight to confirm that we can run  
an EJB workload under stress.  If no changes are made then the  
current SQL syntax is generated and you'll notice no difference.  If  
you want you can add a <select-for-update>true</select-for-update>  
element to the Entity element in your openejb-jar.

I'll post some results when I finish testing.

Cheers.


Matt Hogstrom
matt@hogstrom.org




Mime
View raw message