geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Anita Kulshreshtha (JIRA)" <j...@apache.org>
Subject [jira] Commented: (GERONIMO-2603) Building 1.2 if there are 2.0 artifacts in the repo results in mostly 2.0 artifacts in the server.
Date Tue, 28 Nov 2006 23:59:23 GMT
    [ http://issues.apache.org/jira/browse/GERONIMO-2603?page=comments#action_12454188 ] 
            
Anita Kulshreshtha commented on GERONIMO-2603:
----------------------------------------------

We have two jars claiming to be car-maven-plugin. IIUC, maven will pick the latest version
( a higher number and latest ?) to deal with "car" packaging. How do you make sure that 
1.2 version of car-maven-plugin is being used?

> Building 1.2 if there are 2.0 artifacts in the repo results in mostly 2.0 artifacts in
the server.
> --------------------------------------------------------------------------------------------------
>
>                 Key: GERONIMO-2603
>                 URL: http://issues.apache.org/jira/browse/GERONIMO-2603
>             Project: Geronimo
>          Issue Type: Bug
>      Security Level: public(Regular issues) 
>          Components: buildsystem
>    Affects Versions: 1.2, 2.0
>            Reporter: David Jencks
>         Assigned To: David Jencks
>             Fix For: 1.2, 2.0
>
>
> PackageMojo basically uses the local maven repo to run geronimo off of.  This only really
works if only the versions of geronimo stuff you want are in the repo, otherwise you keep
picking up later versions.
> Solution seems to be to make the repository adapter only let you see the transitive dependencies
of the stuff in your pom.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message