geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vamsavardhana Reddy" <c1vams...@gmail.com>
Subject Re: Building the new trunk
Date Tue, 28 Nov 2006 16:01:15 GMT
Donald,

I tried building trunk using IBM JDK 1.5.0 sometime ago and ran into
problems in the following modules/apps and assemblies.

modules\geronimo-connector
modules\geronimo-j2ee-builder
applications\geronimo-uddi-db
assemblies\geronimo-boilerplate-minimal
assemblies\geronimo-boilerplate-j2ee
assemblies\geronimo-framework
assemblies\geronimo-tomcat-j2ee
assemblies\geronimo-tomcat-minimal
assemblies\geronimo-jetty-j2ee
assemblies\geronimo-jetty-minimal

modules\geronimo-connector gives compilation errors like
C:\GTRUNK\modules\geronimo-connector\src\main\java\org\apache\geronimo\connector\outbound\GeronimoConnectionEventListener.java:[28,34]
package org.apache.commons.logging does not exist.

I got past this error by commenting out the following in pom.xml

            <exclusions>
                <exclusion>
                    <groupId>commons-logging</groupId>
                    <artifactId>commons-logging</artifactId>
                </exclusion>
            </exclusions>

modules\geronimo-j2ee-builder gave the following error.
[INFO] Executing tasks
    [mkdir] Created dir:
C:\GTRUNK\modules\geronimo-j2ee-builder\target\test-ear-j2ee_1.4-
unpacked.ear
    [unzip] Expanding:
C:\GTRUNK\modules\geronimo-j2ee-builder\target\test-ear-j2ee_1.4.ear into
C:\GTRUNK\modules\geronimo-j2ee-builder\target\test-ear-j2ee_1.4-
unpacked.ear
[INFO]
------------------------------------------------------------------------
[ERROR] BUILD ERROR
[INFO]
------------------------------------------------------------------------
[INFO] Error executing ant tasks

Embedded error: Error while expanding
C:\GTRUNK\modules\geronimo-j2ee-builder\target\test-ear-j2ee_1.4.ear
C:\GTRUNK\modules\geronimo-j2ee-builder\target\test-ear-j2ee_1.4.ear (The
system cannot find the file specified.)

applications\geronimo-uddi-db gave the following error.
[INFO]
------------------------------------------------------------------------
[ERROR] BUILD ERROR
[INFO]
------------------------------------------------------------------------
[INFO] Error executing ant tasks

Embedded error: Unable to delete file
C:\GTRUNK\applications\geronimo-uddi-db\target\classes\META-INF\geronimo-uddi-db\var\derby\UddiDatabase\db.lck

assemblies gave the following error
[INFO] Executing tasks
    [mkdir] Created dir:
C:\GTRUNK\assemblies\geronimo-boilerplate-minimal\target\
classes\schema
[INFO]
------------------------------------------------------------------------
[ERROR] BUILD ERROR
[INFO]
------------------------------------------------------------------------
[INFO] Error executing ant tasks

Embedded error:
C:\GTRUNK\assemblies\geronimo-boilerplate-minimal\target\scratch\s
chema not found.

--vamsi

On 11/28/06, Donald Woods <drw_web@yahoo.com> wrote:
>
> I finally got Rev479804 to build on WinXP with a clean m2 repo, using
> Sun Java 1.5.0_09, Maven 2.0.4 with the default .m2 location and the
> source was on a NTFS drive with a path of e:\g20\server\
>
> I'll have to investigate why building with the IBM 1.5.0 SR3 SDK fails
> and generates a lot of Maven warnings like the following -
> [WARNING] Component returned which is not the same manager. Ignored.
> component=
> org.apache.maven.profiles.activation.JdkPrefixProfileActivator@a200a20
> [WARNING] Component returned which is not the same manager. Ignored.
> component=
> org.apache.maven.profiles.activation.OperatingSystemProfileActivator@a200a20
>
>
> -Donald
>
> Christopher M. Cardona wrote:
> > FYI, I was able to build trunk (rev. 478237) successfully this morning:
> > mvn clean install
> >
> > Best wishes,
> > chris
> >
> >
> > anita kulshreshtha wrote:
> >>    Did you get past this problem? I and others have not encountered
> >> this problem..
> >>
> >> Thanks
> >> Anita
> >> --- Donald Woods <drw_web@yahoo.com> wrote:
> >>
> >>
> >>> I'm getting the following j2ee-builder error with a clean repo and
> >>> using the following cmdline to build trunk Rev477664 from this
> morning.
> >>>
> >>> mvn -Dstage=bootstrap -Dmaven.test.skip=true clean install
> >>>
> >>>
> >>> [INFO]
> >>>
> >>
> ----------------------------------------------------------------------------
> >>
> >>
> >>> [INFO] Building Geronimo :: J2EE :: Builder
> >>> [INFO]    task-segment: [clean, install]
> >>> [INFO]
> >>>
> >>
> ----------------------------------------------------------------------------
> >>
> >>
> >>> Downloading:
> >>>
> >>
> http://repository.codehaus.org/org/codehaus/mojo/dependency-maven-plugin/1.0/dependency-maven-plugin-1.0.pom
> >>
> >>
> >>> [WARNING] Unable to get resource from repository codehaus
> >>> (http://repository.codehaus.org)
> >>> Downloading:
> >>>
> >>
> http://repo1.maven.org/maven2/org/codehaus/mojo/dependency-maven-plugin/1.0/dependency-maven-plugin-1.0.pom
> >>
> >>
> >>> 2K downloaded
> >>> Downloading:
> >>> http://repository.codehaus.org/org/codehaus/mojo/mojo/5/mojo-5.pom
> >>> [WARNING] Unable to get resource from repository codehaus
> >>> (http://repository.codehaus.org)
> >>> Downloading:
> >>> http://repo1.maven.org/maven2/org/codehaus/mojo/mojo/5/mojo-5.pom
> >>> 4K downloaded
> >>> Downloading:
> >>>
> >>
> http://repository.codehaus.org/org/codehaus/mojo/dependency-maven-plugin/1.0/dependency-maven-plugin-1.0.jar
> >>
> >>
> >>> [WARNING] Unable to get resource from repository codehaus
> >>> (http://repository.cod
> >>> ehaus.org)
> >>> Downloading:
> >>>
> >>
> http://repo1.maven.org/maven2/org/codehaus/mojo/dependency-maven-plugin/1.0/dependency-maven-plugin-1.0.jar
> >>
> >>
> >>> 15K downloaded
> >>> [INFO] [clean:clean]
> >>> [INFO] Deleting directory
> >>> E:\g20\server\modules\geronimo-j2ee-builder\target
> >>> [INFO] Deleting directory
> >>> E:\g20\server\modules\geronimo-j2ee-builder\target\classes
> >>> [INFO] Deleting directory
> >>> E:\g20\server\modules\geronimo-j2ee-builder\target\test-classes
> >>> [INFO] [tools:require-java-version {execution:
> >>> validate-java-version}]
> >>> [INFO] [xmlbeans:xmlbeans {execution: default}]
> >>> Time to build schema type system: 0.281 seconds
> >>> Time to generate code: 0.609 seconds
> >>> Time to compile code: 2.547 seconds
> >>> [INFO] [tools:copy-legal-files {execution: install-legal-files}]
> >>> [INFO] Created dir:
> >>> E:\g20\server\modules\geronimo-j2ee-builder\target\classes\META-INF
> >>> [INFO] Copying 2 files to
> >>> E:\g20\server\modules\geronimo-j2ee-builder\target\classes\META-INF
> >>> [INFO] [antrun:run {execution: generate-resources}]
> >>> [INFO] Executing tasks
> >>>      [mkdir] Created dir:
> >>> E:\g20\server\modules\geronimo-j2ee-builder\target\clover\classes
> >>>       [copy] Copying 37 files to
> >>> E:\g20\server\modules\geronimo-j2ee-builder\target\clover\classes
> >>> [INFO] Executed tasks
> >>> [INFO] [resources:resources]
> >>> [INFO] Using default encoding to copy filtered resources.
> >>> [INFO] [compiler:compile]
> >>> Compiling 21 source files to
> >>> E:\g20\server\modules\geronimo-j2ee-builder\target\classes
> >>> [INFO] [antrun:run {execution: unpack-test-deployments}]
> >>> [INFO] Executing tasks
> >>>      [mkdir] Created dir:
> >>>
> >> E:\g20\server\modules\geronimo-j2ee-builder\target\test-ear-j2ee_1.4-
> unpacked.ear
> >>
> >>
> >>>      [unzip] Expanding:
> >>>
> >>
> E:\g20\server\modules\geronimo-j2ee-builder\target\test-ear-j2ee_1.4.ear
> >>
> >>> into
> >>>
> >> E:\g20\server\modules\geronimo-j2ee-builder\target\test-ear-j2ee_1.4-
> unpacked.ear
> >>
> >>
> >>> [INFO]
> >>>
> >>
> ------------------------------------------------------------------------
> >>
> >>> [ERROR] BUILD ERROR
> >>> [INFO]
> >>>
> >>
> ------------------------------------------------------------------------
> >>
> >>> [INFO] Error executing ant tasks
> >>>
> >>> Embedded error: Error while expanding
> >>>
> >>
> E:\g20\server\modules\geronimo-j2ee-builder\target\test-ear-j2ee_1.4.ear
> >>
> >>
> E:\g20\server\modules\geronimo-j2ee-builder\target\test-ear-j2ee_1.4.ear
> >>
> >>> (The system cannot find the file specified.)
> >>>
> >>>
> >>>
> >>> I tried manually building the testsupport\ directory and then
> >>> modules\ with the following cmdline -
> >>>     mvn install
> >>> but that didn't fix the above error either...
> >>>
> >>>
> >>> -Donald
> >>>
> >>> anita kulshreshtha wrote:
> >>>
> >>>>   I am using manual build process to build the trunk, mvn
> >>>> -Dstage=bootstrap should also work. It is not necessary to build
> >>>> openejb2 with 1.2-SNAPSHOT jars. The openejb2 can be built using
> >>>> mvn -o -DgeronimoVersion=2.0-SNAPSHOT clean install
> >>>>
> >>>> Thanks
> >>>> Anita
> >>>>
> >>>>
> >>>>
> >>>>
> >>>>
> >>
> ____________________________________________________________________________________
> >>
> >>
> >>>> Sponsored Link
> >>>>
> >>>> Mortgage rates near 39yr lows. $310k for $999/mo. Calculate new
> >>>> payment! www.LowerMyBills.com/lre
> >>>>
> >>>>
> >>>>
> >>
> >>
> >>
> >>
> >>
> ____________________________________________________________________________________
> >>
> >> Sponsored Link
> >>
> >> Rates near 39yr lows. $420,000 Loan for $1399/mo. Calcuate new
> >> payment. www.LowerMyBills.com/lre
> >>
> >>
> >>
> >
> >
> >
>
>
>

Mime
View raw message