geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Paul McMahan" <paulmcma...@gmail.com>
Subject Re: jspc-maven-plugin
Date Tue, 21 Nov 2006 23:06:44 GMT
I see that the jspc 1.4.6 pom has a dependency against jasper-runtime
as well as several other artifacts:

    <dependency>
      <groupId>tomcat</groupId>
      <artifactId>jasper-compiler</artifactId>
      <version>5.5.15</version>
    </dependency>

    <dependency>
      <groupId>tomcat</groupId>
      <artifactId>jasper-compiler-jdt</artifactId>
      <version>5.5.15</version>
    </dependency>

    <dependency>
      <groupId>tomcat</groupId>
      <artifactId>jasper-runtime</artifactId>
      <version>5.5.15</version>
    </dependency>

Maybe having those dependencies in the plugin's pom is the reason we
can safely remove them from the Geronimo poms?  (I am guessing)

Geronimo 2.0 will be using jetty and tomcat v6 which implement the new
JSP spec.  I think that means that for Geronimo 2.0 we'll need a new
version of the jspc maven plugin that references the tomcat v6
artifacts instead of v5.5.15.  Otherwise I think the plugin would not
be able to compile JSP 2.1.  Does that sound right?

Best wishes,
Paul


On 11/21/06, Jeff Genender <jgenender@apache.org> wrote:
> 1.4.6 was a major overhaul. I believe the runtime is only needed during
> the compile stage.  So I think you can ditch it.  Although you will find
> out real quick if it's still needed ;-)
>
> Jeff

Mime
View raw message