geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Guillaume Nodet" <gno...@gmail.com>
Subject Re: svn commit: r467848 - in /geronimo/xbean/trunk/xbean-finder/src: main/java/org/apache/xbean/finder/ test/java/org/acme/foo/ test/java/org/apache/xbean/finder/
Date Thu, 26 Oct 2006 11:27:52 GMT
I guess the problem comes from the maven release plugin
that does not support that.  So it failed to update the
plugin version to 2.8-SNAPSHOT.

On 10/26/06, Jason Dillon <jason@planet57.com> wrote:
> Nope, the problem is that xbean-classloader depends on maven-xbean-
> plugin v2.7 which got lost.  It should depend on ${pom.version} so
> that it picks up the version built in the current build cycle.
>
> --jason
>
>
> On Oct 26, 2006, at 4:14 AM, Guillaume Nodet wrote:
>
> > You can not clean unless you have already build the whole tree.
> > The problems comes from the fact that the maven plugin
> > (which is part of the build) is used in some modules.  It works
> > when you "install", but not when you "clean" from a clean repo.
> >
> > On 10/26/06, Jason Dillon <jason@planet57.com> wrote:
> >> I'd do it.. but trunk does not build:
> >>
> >> <snip>
> >> [INFO]
> >> ---------------------------------------------------------------------
> >> ---
> >> ----
> >> [INFO] Building XBean :: Classloader
> >> [INFO]    task-segment: [clean, install]
> >> [INFO]
> >> ---------------------------------------------------------------------
> >> ---
> >> ----
> >> Downloading: http://repo1.maven.org/maven2/org/apache/xbean/maven-
> >> xbean-plugin/2.7/maven-xbean-plugin-2.7.pom
> >> [WARNING] Unable to get resource from repository central (http://
> >> repo1.maven.org/maven2)
> >> Downloading: http://repo1.maven.org/maven2/org/apache/xbean/maven-
> >> xbean-plugin/2.7/maven-xbean-plugin-2.7.pom
> >> [WARNING] Unable to get resource from repository central (http://
> >> repo1.maven.org/maven2)
> >> [INFO]
> >> ---------------------------------------------------------------------
> >> ---
> >> [ERROR] BUILD ERROR
> >> [INFO]
> >> ---------------------------------------------------------------------
> >> ---
> >> [INFO] Failed to resolve artifact.
> >>
> >> GroupId: org.apache.xbean
> >> ArtifactId: maven-xbean-plugin
> >> Version: 2.7
> >>
> >> Reason: Unable to download the artifact from any repository
> >>
> >>    org.apache.xbean:maven-xbean-plugin:pom:2.7
> >>
> >> from the specified remote repositories:
> >>    central (http://repo1.maven.org/maven2),
> >>    apache.snapshots (http://people.apache.org/repo/m2-snapshot-
> >> repository),
> >>    apache-snapshots (http://people.apache.org/repo/m2-snapshot-
> >> repository)
> >> </snip>
> >>
> >> --jason
> >>
> >>
> >> On Oct 26, 2006, at 3:39 AM, Jacek Laskowski wrote:
> >>
> >> > On 10/26/06, Guillaume Nodet <gnodet@gmail.com> wrote:
> >> >> Unfortunately, xbean-2.7 has been lost this weekend.
> >> >> If still have the full xbean repo on my computer so I will
> >> >> upload it as soon as permissions are fixed.
> >> >>
> >> >> And afaik, there were no xbean-2.8 snapshots uploaded
> >> >> (at least, not by me).
> >> >
> >> > May I ask for 2.8-SNAPSHOT deploy once, for your OpenEJB
> >> fellows? ;-)
> >> >
> >> > Jacek
> >> >
> >> > --
> >> > Jacek Laskowski
> >> > http://www.jaceklaskowski.pl
> >>
> >>
> >
> >
> > --
> > Cheers,
> > Guillaume Nodet
>
>


-- 
Cheers,
Guillaume Nodet

Mime
View raw message