geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Jencks <david_jen...@yahoo.com>
Subject Re: unable to "mvn compile:: missing of geronimo-schema-j2ee_1.4:jar:1.0-SNAPSHOT
Date Fri, 27 Oct 2006 08:08:06 GMT
I'm a bit confused by this, geronimo trunk appears to depend on  
version 1.1-SNAPSHOT of the schema jar.  Can you check that you are  
up to date with svn? If this is not the problem please run mvn -X in  
the module that fails to build and show it on the list.  Be sure to  
include which module is having the problem

thanks
david jencks

On Oct 26, 2006, at 10:59 PM, Man-Chi Leung wrote:

> hi,
>
> sorry, I am new to geronimo, I encountered error during compiling  
> from maven2, after I checkout the latest source tree at the first  
> time.
> when I check http://people.apache.org/repo/m2-snapshot-repository/ 
> org/apache/geronimo/schema/geronimo-schema-j2ee_1.4/, this is only  
> 1.1-SNAPSHOT. not 1.0.
> how can I solve this problem? pls help !
>
> $mvn compile
>
> ...
> ...
> Downloading: http://people.apache.org/repo/m2-snapshot-repository/ 
> org/apache/geronimo/schema/geronimo-schema-j2ee_1.4/1.0-SNAPSHOT/ 
> geronimo-schema-j2ee_1.4-1.0-SNAPSHOT.jar
> [WARNING]
> Unable to get resource from repository apache.snapshots (http:// 
> people.apache.org/repo/m2-snapshot-repository)
> [INFO]  
> ---------------------------------------------------------------------- 
> --
> [ERROR] BUILD ERROR
> [INFO]  
> ---------------------------------------------------------------------- 
> --
> [INFO] Failed to resolve artifact.
>
> Missing:
> ----------
> 1) org.apache.geronimo.schema:geronimo-schema-j2ee_1.4:jar:1.0- 
> SNAPSHOT
>
>  Try downloading the file manually from the project website.
>
>  Then, install it using the command:
>      mvn install:install-file -DgroupId=org.apache.geronimo.schema - 
> DartifactId=geronimo-schema-j2ee_1.4 \
>          -Dversion=1.0-SNAPSHOT -Dpackaging=jar -Dfile=/path/to/file
>
>  Path to dependency:
>        1) org.apache.geronimo.modules:geronimo-j2ee-schema:jar:1.2- 
> SNAPSHOT
>        2) org.apache.geronimo.schema:geronimo-schema-j2ee_1.4:jar: 
> 1.0-SNAPSHOT
>
> ----------
> 1 required artifact is missing.
>
> for artifact:
>


Mime
View raw message