geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Aaron Mulder" <ammul...@alumni.princeton.edu>
Subject Spring in Geronimo 1.1.1
Date Thu, 12 Oct 2006 02:20:19 GMT
I thought we had gotten rid of this but...

It looks like in Geronimo 1.1.1, the Jetty server configuration
includes Spring 1.2.5 on its class path.

Unfortunately, this means that no web application can use any other
version of Spring that it inherits from a class path parent.  It can
package its own Spring, but not, for example, use Spring 2.0 classes
configured in a parent module (e.g. to share common Spring classes or
services packaged in a parent module).

Let's say we were going to release a 1.1.2 and we were going to drop
WADI, Spring, and ActiveCluster from the Jetty module in that
release... Would that break anybody's heart?

Thanks,
      Aaron


geronimo/jetty/1.1.1/car
-------------
repository/geronimo/geronimo-jetty/1.1.1/geronimo-jetty-1.1.1.jar
repository/jetty/org.mortbay.jetty/5.1.10/org.mortbay.jetty-5.1.10.jar
repository/tomcat/jasper-compiler/5.5.15/jasper-compiler-5.5.15.jar
repository/tomcat/jasper-compiler-jdt/5.5.15/jasper-compiler-jdt-5.5.15.jar
repository/tomcat/jasper-runtime/5.5.15/jasper-runtime-5.5.15.jar
repository/commons-el/commons-el/1.0/commons-el-1.0.jar
repository/springframework/spring/1.2.5/spring-1.2.5.jar
repository/activecluster/activecluster/1.2-20051115174934/activecluster-1.2-20051115174934.jar
repository/wadi/wadi-core/2.0M1/wadi-core-2.0M1.jar
repository/wadi/wadi-jetty5/2.0M1/wadi-jetty5-2.0M1.jar

Mime
View raw message