geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vamsavardhana Reddy (JIRA)" <>
Subject [jira] Commented: (GERONIMO-2393) Maven eclipse plugin is generating invalid classpath entries in .classpath
Date Thu, 05 Oct 2006 05:09:20 GMT
    [ ] 
Vamsavardhana Reddy commented on GERONIMO-2393:

URGH...  I will have to withdraw my previous comment that Sun JDK v1.4.2_12 solved it.  The
problem has not gone away.  I did a fresh checkout and bootstrap on a machine that had Sun
JDK 1.4.2_09 and noticed that the classpath entries are fine.  Afterward that I installed
Sun JDK1.4.2_12 on my machine and ran mvn eclipse:eclipse under a specific directory (modules\geronimo-tomcat)
and noticed that the classpath entries are alright (this was before a reboot once JDK1.4.2_12
is installed.  I do not know if the reboot has any effect on the current issue).  I thought
the problem is solved.  After a later run of mvn eclipse:eclipse, I am still left with incorrect
classpath entries. HELP!!!!

> Maven eclipse plugin is generating invalid classpath entries in .classpath
> --------------------------------------------------------------------------
>                 Key: GERONIMO-2393
>                 URL:
>             Project: Geronimo
>          Issue Type: Bug
>      Security Level: public(Regular issues) 
>          Components: buildsystem
>    Affects Versions: 1.2
>         Environment: WinXP, G TRUNK
>            Reporter: Vamsavardhana Reddy
>             Fix For: 1.2
>         Attachments: .classpath, .classpath
> I have run mvn eclipse:eclipse.  Upon importing the projects into eclipse, I am noticing
the the classpath entries generated have the first letter missing.  Here is an example of
some classpath entries in .classpath file.
>   <classpathentry kind="var" path="M2_REPO/ommons-cli/commons-cli/1.0/commons-cli-1.0.jar"/>
>   <classpathentry kind="var" path="M2_REPO/tax/stax-api/1.0/stax-api-1.0.jar"/>
>   <classpathentry kind="var" path="M2_REPO/lassworlds/classworlds/1.1-alpha-2/classworlds-1.1-alpha-2.jar"/>
>   <classpathentry kind="var" path="M2_REPO/rg/apache/maven/maven-repository-metadata/2.0.4/maven-repository-metadata-2.0.4.jar"/>

This message is automatically generated by JIRA.
If you think it was sent incorrectly contact one of the administrators:
For more information on JIRA, see:


View raw message