geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jason Dillon <ja...@planet57.com>
Subject Re: [jira] Commented: (GERONIMO-2393) Maven eclipse plugin is generating invalid classpath entries in .classpath
Date Wed, 04 Oct 2006 06:16:17 GMT
I recommend that you ask the users list and/or hop in #maven on  
irc.codehaus.org and ask them about it.

It sounds like a problem with the eclipse maven plugin... or your  
environment.  But either way, I recommend going to the source for  
more detailed help.

--jason


On Oct 3, 2006, at 10:59 PM, Vamsavardhana Reddy wrote:

> I have not asked the Maven folks.
>
> I use English-US locale.
>
> --vamsi
>
> On 10/4/06, Jason Dillon <jason@planet57.com> wrote:
> Have you asked the Maven folks about this?
>
> Is your system using a specific locale?
>
> --jason
>
>
> On Oct 3, 2006, at 10:30 PM, Vamsavardhana Reddy wrote:
>
>> Running mvn eclipse:eclipse is not giving any errors.  But the  
>> entries in .classpath have the first letter missing.
>>
>> Vamsi
>>
>> On 10/4/06, Jason Dillon < jason@planet57.com> wrote:
>> What is the exact error?  Can can you run with -X to produce some  
>> debug output.
>>
>> --jason
>>
>>
>> On Oct 3, 2006, at 10:24 PM, Vamsavardhana Reddy wrote:
>>
>>> Can someone who is not facing this eclipse .classpath problem zip  
>>> the .classpath files from their source tree and send it to my id  
>>> c1vamsi1c@gmail.com .
>>>
>>> Thanks,
>>> Vamsi
>>> On 10/4/06, Jason Dillon <jason@planet57.com > wrote:
>>> I don't think that is the problem... as I can `mvn  
>>> eclipse:eclipse` just fine and it downloads the maven-eclipse- 
>>> plugin v2.2.
>>>
>>> Maybe some metadata in your local repo is corrupt?
>>>
>>> --jason
>>>
>>>
>>> On Oct 3, 2006, at 9:29 PM, Vamsavardhana Reddy wrote:
>>>
>>>> How do I do that?
>>>>
>>>> Because of this classpath entry problem, I am really stranded in  
>>>> using Eclipse for development on G TRUNK.  I will have to look  
>>>> for a work around, like getting this .classpath files from  
>>>> someone who is not seeing this problem and overwrite the ones I  
>>>> have.
>>>>
>>>> --vamsi
>>>> On 10/4/06, Jason Dillon < jason@planet57.com> wrote:
>>>> Configure a version for the eclipse plugin.
>>>>
>>>> --jason
>>>>
>>>>
>>>> On Oct 3, 2006, at 8:52 PM, Vamsavardhana Reddy wrote:
>>>>
>>>>> Has anyone else faced this problem with .classpath entries?   
>>>>> See http://issues.apache.org/jira/browse/GERONIMO-2393 for  
>>>>> details.
>>>>>
>>>>> Thanks,
>>>>> Vamsi
>>>>>
>>>>> On 10/4/06, Vamsavardhana Reddy (JIRA) <  
>>>>> dev@geronimo.apache.org> wrote:
>>>>>     [ http://issues.apache.org/jira/browse/GERONIMO-2393? 
>>>>> page=comments#action_12439718 ]
>>>>>
>>>>> Vamsavardhana Reddy commented on GERONIMO-2393:
>>>>> -----------------------------------------------
>>>>>
>>>>> Anita,  I am getting the following error upon deleting .m2/o/a/ 
>>>>> maven/plugins/maven-eclipse-plugin and then running mvn  
>>>>> eclipse:eclipse :
>>>>>
>>>>> [INFO] Scanning for projects...
>>>>> [INFO] Searching repository for plugin with prefix: 'eclipse'.
>>>>> [INFO]  
>>>>> ------------------------------------------------------------------ 
>>>>> ------
>>>>> [ERROR] BUILD ERROR
>>>>> [INFO]  
>>>>> ------------------------------------------------------------------ 
>>>>> ------
>>>>> [INFO] The plugin 'org.apache.maven.plugins:maven-eclipse- 
>>>>> plugin' does not exist
>>>>> or no valid version could be found
>>>>> [INFO]  
>>>>> ------------------------------------------------------------------ 
>>>>> ------
>>>>> [INFO] For more information, run Maven with the -e switch
>>>>> [INFO]  
>>>>> ------------------------------------------------------------------ 
>>>>> ------
>>>>> [INFO] Total time: < 1 second
>>>>> [INFO] Finished at: Wed Oct 04 09:14:34 IST 2006
>>>>> [INFO] Final Memory: 1M/2M
>>>>> [INFO]  
>>>>> ------------------------------------------------------------------ 
>>>>> ------
>>>>>
>>>>>
>>>>> > Maven eclipse plugin is generating invalid classpath entries  
>>>>> in .classpath
>>>>> >  
>>>>> ------------------------------------------------------------------ 
>>>>> --------
>>>>> >
>>>>> >                 Key: GERONIMO-2393
>>>>> >                 URL: http://issues.apache.org/jira/browse/ 
>>>>> GERONIMO-2393
>>>>> >             Project: Geronimo
>>>>> >          Issue Type: Bug
>>>>> >      Security Level: public(Regular issues)
>>>>> >          Components: buildsystem
>>>>> >    Affects Versions: 1.2
>>>>> >         Environment: WinXP, G TRUNK
>>>>> >            Reporter: Vamsavardhana Reddy
>>>>> >             Fix For: 1.2
>>>>> >
>>>>> >         Attachments: .classpath, .classpath
>>>>> >
>>>>> >
>>>>> > I have run mvn eclipse:eclipse.  Upon importing the projects  
>>>>> into eclipse, I am noticing the the classpath entries generated  
>>>>> have the first letter missing.  Here is an example of some  
>>>>> classpath entries in .classpath file.
>>>>> >   <classpathentry kind="var" path="M2_REPO/ommons-cli/commons-

>>>>> cli/1.0/commons-cli-1.0.jar"/>
>>>>> >   <classpathentry kind="var" path="M2_REPO/tax/stax-api/1.0/

>>>>> stax- api-1.0.jar"/>
>>>>> >   <classpathentry kind="var" path="M2_REPO/lassworlds/ 
>>>>> classworlds/1.1-alpha-2/classworlds-1.1-alpha-2.jar"/>
>>>>> >   <classpathentry kind="var" path="M2_REPO/rg/apache/maven/ 
>>>>> maven-repository-metadata/2.0.4/maven- repository- 
>>>>> metadata-2.0.4.jar"/>
>>>>>
>>>>> --
>>>>> This message is automatically generated by JIRA.
>>>>> -
>>>>> If you think it was sent incorrectly contact one of the  
>>>>> administrators: http://issues.apache.org/jira/secure/ 
>>>>> Administrators.jspa
>>>>> -
>>>>> For more information on JIRA, see: http://www.atlassian.com/ 
>>>>> software/jira
>>>>>
>>>>>
>>>>>
>>>>
>>>>
>>>
>>>
>>
>>
>
>


Mime
View raw message