geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joe Bohn <joe.b...@earthlink.net>
Subject Re: http://geronimo.apache.org/plugins?
Date Wed, 04 Oct 2006 15:51:06 GMT
I attempted to use geronimo 1.1 and deploy the web console on little-G 
with this plugin repo.  I hit some problems that I think are related to 
the information that is published (or not) in http://repo1.maven.org/maven2/


For both jetty and tomcat I received the following error on the server:
11:29:09,875 ERROR [PluginInstallerGBean] Cannot find plugin index at 
site http://geronimo.apache.org/1.1/repository/geronimo-plugins.xml
############################################################
# Installed configuration
#   id = geronimo/webconsole-tomcat/1.1/car
#   location = 
C:\g-images\1.1\tomcat-lg\geronimo-1.1\repository\geronimo\webconsole-tomcat\1.1\webconsole-tomcat-1.1.car
############################################################
############################################################
# Installed configuration
#   id = geronimo/system-database/1.0/car
#   location = 
C:\g-images\1.1\tomcat-lg\geronimo-1.1\repository\geronimo\system-database\1.0\system-database-1.0.car
############################################################
11:30:24,578 WARN  [ConfigurationStoreUtil] Checksum file not found: 
C:\g-images\1.1\tomcat-lg\geronimo-1.1\repository\geronimo\system-database\1.0\system-datab
ase-1.0.car\META-INF\config.ser.sha1

I'm not sure what the initial error is with finding the plugin index ... 
but it seems to continue and download the webconsole car in spite of it 
... so I don't know if it's a real error or just a bogus message.

After that it attempts to download the 1.0 system-database rather than 
the 1.1 version.  I think this was the same problem that I originally 
had with geronimoplugins.com a while back.  In that case Aaron updated 
the metadata on the geronimoplugins repo.

The metadata in http://repo1.maven.org/maven2/geronimo/webconsole-jetty/ 
currently only references 1.0 (which is also the only version that 
includes a pom.xml in the repo).  Am I correct in thinking that we need 
to get both the metadata updated and the poms published on the repo 
before this will work?

Thanks,
Joe


Paul McMahan wrote:
> I added catalogs for the 1.1 and 1.1.1 plugins at
> http://geronimo.apache.org/plugins/.  They point at the plugins hosted
> at http://repo1.maven.org/maven2/.
> 
> I also added a catalog for the 1.2-SNAPSHOT plugins pointing at the
> snapshot repository
> http://people.apache.org/repo/m2-snapshot-repository/
> This will start to work if/when the 1.2 snapshot configs get published.
> 
> For anyone interested in the play-by-play :-) the next steps I had in 
> mind are:
> -  publish 1.2-SNAPSHOT configs so we can install plugins from geronimo's
>   snapshot builds (need some guidance here on how to publish)
> -  update config.xml to get the repository list from geronimo.apache.org
>   as discussed in this thread:
>   
> http://www.nabble.com/plugin-repository-list-URL-in-config.xml-tf2247272.html 
> 
> -  figure out a way to generate the catalog during the build process
> -  look into the idea Jason suggested for publishing the plugin
> catalogs directly
>   in the repository
> 
> Best wishes,
> Paul
> 
> 

Mime
View raw message