geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vamsavardhana Reddy" <c1vams...@gmail.com>
Subject Re: [jira] Commented: (GERONIMO-2393) Maven eclipse plugin is generating invalid classpath entries in .classpath
Date Wed, 04 Oct 2006 03:52:17 GMT
Has anyone else faced this problem with .classpath entries?  See
http://issues.apache.org/jira/browse/GERONIMO-2393 for details.

Thanks,
Vamsi

On 10/4/06, Vamsavardhana Reddy (JIRA) <dev@geronimo.apache.org> wrote:
>
>     [
> http://issues.apache.org/jira/browse/GERONIMO-2393?page=comments#action_12439718]
>
> Vamsavardhana Reddy commented on GERONIMO-2393:
> -----------------------------------------------
>
> Anita,  I am getting the following error upon deleting
> .m2/o/a/maven/plugins/maven-eclipse-plugin and then running mvn
> eclipse:eclipse :
>
> [INFO] Scanning for projects...
> [INFO] Searching repository for plugin with prefix: 'eclipse'.
> [INFO]
> ------------------------------------------------------------------------
> [ERROR] BUILD ERROR
> [INFO]
> ------------------------------------------------------------------------
> [INFO] The plugin 'org.apache.maven.plugins:maven-eclipse-plugin' does not
> exist
> or no valid version could be found
> [INFO]
> ------------------------------------------------------------------------
> [INFO] For more information, run Maven with the -e switch
> [INFO]
> ------------------------------------------------------------------------
> [INFO] Total time: < 1 second
> [INFO] Finished at: Wed Oct 04 09:14:34 IST 2006
> [INFO] Final Memory: 1M/2M
> [INFO]
> ------------------------------------------------------------------------
>
>
> > Maven eclipse plugin is generating invalid classpath entries in
> .classpath
> >
> --------------------------------------------------------------------------
> >
> >                 Key: GERONIMO-2393
> >                 URL: http://issues.apache.org/jira/browse/GERONIMO-2393
> >             Project: Geronimo
> >          Issue Type: Bug
> >      Security Level: public(Regular issues)
> >          Components: buildsystem
> >    Affects Versions: 1.2
> >         Environment: WinXP, G TRUNK
> >            Reporter: Vamsavardhana Reddy
> >             Fix For: 1.2
> >
> >         Attachments: .classpath, .classpath
> >
> >
> > I have run mvn eclipse:eclipse.  Upon importing the projects into
> eclipse, I am noticing the the classpath entries generated have the first
> letter missing.  Here is an example of some classpath entries in .classpath
> file.
> >   <classpathentry kind="var"
> path="M2_REPO/ommons-cli/commons-cli/1.0/commons-cli-1.0.jar"/>
> >   <classpathentry kind="var" path="M2_REPO/tax/stax-api/1.0/stax-
> api-1.0.jar"/>
> >   <classpathentry kind="var"
> path="M2_REPO/lassworlds/classworlds/1.1-alpha-2/classworlds-
> 1.1-alpha-2.jar"/>
> >   <classpathentry kind="var"
> path="M2_REPO/rg/apache/maven/maven-repository-metadata/2.0.4/maven-
> repository-metadata-2.0.4.jar"/>
>
> --
> This message is automatically generated by JIRA.
> -
> If you think it was sent incorrectly contact one of the administrators:
> http://issues.apache.org/jira/secure/Administrators.jspa
> -
> For more information on JIRA, see: http://www.atlassian.com/software/jira
>
>
>

Mime
View raw message