geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Paul McMahan" <paulmcma...@gmail.com>
Subject Re: unable to "mvn compile:: missing of geronimo-schema-j2ee_1.4:jar:1.0-SNAPSHOT
Date Fri, 27 Oct 2006 12:53:42 GMT
I hit the compile problem yesterday too and used the same work around
as Vamsi.  Then I noticed when r468129 got committed it made the
following change.  I assumed it fixes the problem but I haven't
removed my work around yet to test...

--- geronimo/server/trunk/modules/geronimo-j2ee-schema/src/main/resources/META-INF/geronimo-dependency.xml
(original)
+++ geronimo/server/trunk/modules/geronimo-j2ee-schema/src/main/resources/META-INF/geronimo-dependency.xml
Thu Oct 26 13:53:22 2006
@@ -21,6 +21,5 @@
    <dep:dependency>
        <dep:groupId>org.apache.geronimo.schema</dep:groupId>
        <dep:artifactId>geronimo-schema-j2ee_1.4</dep:artifactId>
-        <dep:version>1.0-SNAPSHOT</dep:version>
    </dep:dependency>
 </dep:service>


Best wishes,
Paul

On 10/27/06, Jacek Laskowski <jacek@laskowski.net.pl> wrote:
> On 10/27/06, David Jencks <david_jencks@yahoo.com> wrote:
> > I'm a bit confused by this, geronimo trunk appears to depend on
> > version 1.1-SNAPSHOT of the schema jar.  Can you check that you are
> > up to date with svn? If this is not the problem please run mvn -X in
> > the module that fails to build and show it on the list.  Be sure to
> > include which module is having the problem
>
> I concur. I double-checked the bits and all seem to be fine. I meant
> to have replied along your lines, but Vamsi got me withdraw it. Can it
> be that some jars in the repos are outdated (with the 1.0-SNAPSHOT
> dependency)?
>
> Jacek
>
> --
> Jacek Laskowski
> http://www.jaceklaskowski.pl
>

Mime
View raw message