geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From anita kulshreshtha <a_kuls...@yahoo.com>
Subject Re: Clover plugin
Date Mon, 09 Oct 2006 12:26:11 GMT


Jason Dillon <jason@planet57.com> wrote: Why?  If we turn clover back on, then these
classes will need to be copied to target/clover/classes anyways.




What is the problem with Eclipse?

Currently if we use 'target' as the default output folder in eclipse, the schemaorg_apache_xmlbeans
classes are lost. We are manually adding target/clover/classes as 'classes folder'  to the
BuildPath for *-builder modules. If clover is not particular about this location, we could
use a neutral name like xmlbeans-classes. WDYS? 
 
 Thanks
 Anita



--jason



On Oct 8, 2006, at 6:01 AM, anita kulshreshtha wrote:

     I would like to copy xmlbeans classes to target/xmlbeans-classes instead of target/clover/classes.
This directory will be used by Eclipse. We are currently using target/clover/classes for this
purpose.


thanks
Anita

Jason Dillon <jason@planet57.com> wrote: That and clover caused to many problems...
but there is a new version  
of the plugin out, need to revisit.

--jason


On Oct 6, 2006, at 8:31 AM, Prasad Kashyap wrote:

> Hi Anita,
>
> The clover plugin is used to get test coverage on our modules. Eg:
> http://geronimo.apache.org/maven/server/modules/geronimo-activation/ 
> clover/index.html
>
> But I don't see the maven-clover-plugin being executed along with the
> other reports in the genesis' project-config. I don't know where it it
> is being called from.
>
> Cheers
> Prasad
>
> On 10/6/06, anita kulshreshtha  wrote:
>>
>> The *-builder modules are copying schemaorg_apache_xmlbeans  
>> classes to
>> target/clover/classes. I was trying to import *-builder in  
>> eclipse. Eclipse
>> is not handing these classes properly and I am getting  
>> ".........can not be
>> resolved" errors. This needs to be fixed.
>>
>> Thanks
>> Anita
>>
>> ----- Original Message ----
>> From: Jacek Laskowski 
>> To: dev@geronimo.apache.org
>> Sent: Friday, October 6, 2006 9:40:35 AM
>> Subject: Re: Clover plugin
>>
>>
>> On 10/6/06, anita kulshreshtha  wrote:
>> >
>> > Oops! I should have stated the question more clearly. I do mean  
>> how it is
>> > being used in Geronimo?
>>
>> I can't find any reference to clover plugin in poms (as a report) so
>> unless someone runs it via  mvn clover:instrument clover:clover it's
>> not used at all.
>>
>> Why?
>>
>> Jacek
>>
>> --
>> Jacek Laskowski
>> http://www.laskowski.net.pl
>>
>>
>>


      


---------------------------------
Get your own web address for just $1.99/1st yr. We'll help. Yahoo! Small Business.




 		
---------------------------------
Do you Yahoo!?
 Get on board. You're invited to try the new Yahoo! Mail.
Mime
View raw message