geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From anita kulshreshtha <a_kuls...@yahoo.com>
Subject Re: [jira] Commented: (GERONIMO-2393) Maven eclipse plugin is generating invalid classpath entries in .classpath
Date Wed, 04 Oct 2006 12:02:51 GMT
Vamsi,
    I am attaching an eclipse.log generated by running mvn -o eclipse:eclipse on geronimo-tomcat
module directory. Do you get the same output? Does the 'List of artifacts....' have full names?
If the .classpath file is corrupt, it has nothing to do with eclipse version. The problem
occurs even before importing into eclipse. Which directory are you running the command from?

Thanks
Anita

----- Original Message ----
From: Vamsavardhana Reddy <c1vamsi1c@gmail.com>
To: dev@geronimo.apache.org
Sent: Wednesday, October 4, 2006 12:43:31 AM
Subject: Re: [jira] Commented: (GERONIMO-2393) Maven eclipse plugin is generating invalid
classpath entries in .classpath

I tried that too after my last e-mail.  It didn't help.  Do
you think it has anything to do with the eclipse version I have? 
I am using Version: 3.1.1 Build id: M20050929-0840



--vamsi
On 10/4/06, anita kulshreshtha <a_kulshre@yahoo.com> wrote:
I
just ran mvn -o eclipse:eclipse and it works fine. Did you delete
.project and .classpath files? try deleting them in one of the modules
and run mvn -o eclipse:eclipse. 

Thanks
Anita

----- Original Message ----
From: Vamsavardhana Reddy (JIRA) <
dev@geronimo.apache.org>
To: 
dev@geronimo.apache.org
Sent: Wednesday, October 4, 2006 12:21:20 AM
Subject: [jira] Commented: (GERONIMO-2393) Maven eclipse plugin is generating invalid classpath
entries in .classpath


    [ http://issues.apache.org/jira/browse/GERONIMO-2393?page=comments#action_12439721
 ] 
            
Vamsavardhana Reddy commented on GERONIMO-2393:
-----------------------------------------------

Anita,
Ignore my previous comment.  That error was due to something
else.  I re ran mvn eclipse:eclipse after
deleting  .m2/o/a/maven/plugins/maven-eclipse-plugin .  I still see the same problem with
entries in .classpath

> Maven eclipse plugin is generating invalid classpath entries in .classpath
> --------------------------------------------------------------------------

>
>                 Key:
 GERONIMO-2393
>                 URL: http://issues.apache.org/jira/browse/GERONIMO-2393

>             Project: Geronimo
>          Issue Type: Bug
>      Security Level: public(Regular issues) 
>          Components: buildsystem
>    Affects Versions: 1.2
>         Environment: WinXP, G TRUNK

>            Reporter: Vamsavardhana Reddy
>             Fix For:
 1.2
>
>         Attachments: .classpath, .classpath
>
>
>
I have run mvn eclipse:eclipse.  Upon importing the projects
into eclipse, I am noticing the the classpath entries generated have
the first letter missing.  Here is an example of some
classpath entries in .classpath file.
>   <classpathentry kind="var" path="M2_REPO/ommons-cli/commons-cli/1.0/commons-cli-1.0.jar"/>
>   <classpathentry kind="var" path="M2_REPO/tax/stax-api/1.0/stax-
api-1.0.jar"/>
>   <classpathentry kind="var" path="M2_REPO/lassworlds/classworlds/1.1-alpha-2/classworlds-1.1-alpha-2.jar"/>
>   <classpathentry kind="var" path="M2_REPO/rg/apache/maven/maven-repository-metadata/2.0.4/maven-
repository-metadata-2.0.4.jar"/>

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly
 contact one of the administrators: http://issues.apache.org/jira/secure/Administrators.jspa

-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        


















Mime
View raw message