geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Prasad Kashyap" <goyathlay.geron...@gmail.com>
Subject Re: Server built from trunk trying to reference artifact_aliases.properties
Date Thu, 21 Sep 2006 20:29:33 GMT
I did an svn update and it got that one file that David changed.  I
then rebuilt all of the assemblies and the problem still occurred. I
moved on by just dropping the file into var/config.

I shall soon be doing a fresh checkout and a full rebuild.

Cheers
Prasad

On 9/21/06, Joe Bohn <joe.bohn@earthlink.net> wrote:
> Chris & David,
>
> The file is getting created in each of the assemblies for me so I'm not
> seeing the same thing as Chris.  I did a complete rebuild (including a
> full bootstrap).
>
> Joe
>
>
> Christopher M. Cardona wrote:
> > After rebuilding G I can see artifact_aliases.properties only in the
> > geronimo-boilerplate-minimal assembly. Other assemblies like
> > geronimo-jetty-j2ee and geronimo-tomcat-j2ee don't have it so running
> > the corresponding servers for those throws the FNFE. Now I'm not sure if
> > building G should have included artifact_aliases.properties in the other
> > assemblies and not just geronimo-boilerplate-minimal or there is
> > something wrong in the way I'm rebuilding G.
> >
> > chris
> >
> > David Jencks wrote:
> >
> >>
> >> On Sep 21, 2006, at 12:57 AM, Christopher M. Cardona wrote:
> >>
> >>> David,
> >>>
> >>> I did an svn update to pick up your properties file then rebuilt G
> >>> but I still get the same problem. Creating the
> >>> artifact_aliases.properties file under
> >>> geronimo-tomcat-j2ee-1.2-SNAPSHOT/var/config/ fixed the problem and I
> >>> was able to start the server. Not sure if you need to include
> >>> artifact_aliases.properties in other assemblies like
> >>> geronimo-tomcat-j2ee.
> >>
> >>
> >> I can't reproduce this problem on my cleaner copy of geronimo. I
> >> included the new artifact_aliases.properties in the
> >> geronimo-boilerplate-minimal configuration, are you sure that you
> >> rebuilt that one, and can you check if the new file is included in
> >> that assembly?
> >>
> >> thanks
> >> david jencks
> >>
> >>>
> >>> Best wishes,
> >>> chris
> >>>
> >>> David Jencks wrote:
> >>>
> >>>> I think I've fixed this, please verify.
> >>>>
> >>>> I included a properties file in the correct location with some basic
> >>>> instructions and no entries. Does this seem reasonable?
> >>>>
> >>>> thanks
> >>>> david jencks
> >>>>
> >>>> On Sep 20, 2006, at 1:29 PM, Prasad Kashyap wrote:
> >>>>
> >>>>> While trying to run a server that I built from trunk, I get the
> >>>>> following exception
> >>>>>
> >>>>> Booting Geronimo Kernel (in Java 1.4.2_10)...
> >>>>> 16:33:58,566 ERROR [GBeanInstanceState] Error while starting; GBean
> >>>>> is now in
> >>>>> the FAILED state:
> >>>>> abstractName="org.apache.geronimo.configs/j2ee-system/1.2-SNAPSHOT/car?ServiceModule=org.apache.geronimo.configs/j2ee-system/1.2-SNAPSHOT/car,j2eeType=ArtifactResolver,name=ArtifactResolver"
> >>>>>
> >>>>> java.io.FileNotFoundException:
> >>>>> /home/pmcmahan/src/geronimo/trunk/assemblies/geronimo-tomcat-j2ee/target/geronimo-tomcat-j2ee-1.2-SNAPSHOT/var/config/artifact_aliases.properties
> >>>>>
> >>>>> (No such file or directory)
> >>>>> at java.io.FileInputStream.open(Native Method)
> >>>>> at java.io.FileInputStream.<init>(FileInputStream.java:106)
> >>>>> at
> >>>>> org.apache.geronimo.system.resolver.ExplicitDefaultArtifactResolver.buildExplicitResolution(ExplicitDefaultArtifactResolver.java:55)
> >>>>>
> >>>>> at
> >>>>> org.apache.geronimo.system.resolver.ExplicitDefaultArtifactResolver.<init>(ExplicitDefaultArtifactResolver.java:47)
> >>>>>
> >>>>>
> >>>>>
> >>>>> Cheers
> >>>>> Prasad
> >>>>
> >>>>
> >>>>
> >>>
> >>
> >>
> >
> >
> >
>

Mime
View raw message