geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jason Dillon <ja...@planet57.com>
Subject Re: Build error with bootstrap assemble
Date Sat, 30 Sep 2006 08:50:24 GMT
Run `mvn -U` to make sure you have the latest snapshots.... or `rm - 
rf ~/.m2/repository/org/apache/geronimo/genesis/`.

Genesis tools-maven-plugin was updated earlier to add some new  
packagings.

Also make sure the top-level pom.xml is up to date, it could have:

<plugin>
                 <groupId>org.apache.geronimo.genesis.plugins</groupId>
                 <artifactId>tools-maven-plugin</artifactId>

                 <!-- Tools includes custom packagings, install as  
extention to pick them up -->
                 <extensions>true</extensions>
...

--jason


On Sep 30, 2006, at 1:19 AM, Vamsavardhana Reddy wrote:

> I am getting the following error when running bootstrap assmble.   
> Any suggestions on how to overcome this?
>
> [INFO] Building Geronimo Assemblies :: Minimal Framework
> [INFO]    task-segment: [install]
> [INFO]  
> ---------------------------------------------------------------------- 
> ---
> ---
> [INFO]  
> ---------------------------------------------------------------------- 
> --
> [ERROR] BUILD ERROR
> [INFO]  
> ---------------------------------------------------------------------- 
> --
> [INFO] Cannot find lifecycle mapping for packaging: 'application- 
> assembly'.
> Component descriptor cannot be found in the component repository:  
> org.apache.mav
> en.lifecycle.mapping.LifecycleMappingapplication-assembly.
> [INFO]  
> ---------------------------------------------------------------------- 
> --
> [INFO] For more information, run Maven with the -e switch
> [INFO]  
> ---------------------------------------------------------------------- 
> --
> [INFO] Total time: 6 minutes 44 seconds
> [INFO] Finished at: Sat Sep 30 13:44:24 IST 2006
> [INFO] Final Memory: 61M/111M


Mime
View raw message