geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rick McGuire <rick...@gmail.com>
Subject An extremely unexpected result running with yoko...
Date Fri, 22 Sep 2006 14:30:07 GMT
I finally got a Geronimo build created with both yoko and sun CORBA 
configs.  The yoko config ran fine, and I was trying to figure out what 
tweaking was necessary to get the sun version to work.  At a minimum, I 
figured I would need to remove the yoko jar files from the repository.  
Imagine my surprise when the sun j2ee-corba config started up just fine, 
with no change at all to the assembly.  I was able to continually switch 
back and forth between between the yoko and sun ORBs without any 
failures.  It appears that the yoko ORB is incompatible with the sun 
version of the org.omg.* classes, but the reverse is not true.  The Sun 
ORB appears to work well with the yoko spec classes on the classpath.  
Not at all what I expected, but certainly a satisfying development!

I did an additional experiment, and tweaked the sun configuration to use 
a different set of listener ports.  Using different listeners, I was 
even able to start both ORB configurations at the same time!  I was only 
able to do this manually.  There appear to be some timing issues with 
trying to load both at startup.  Since both ORB configurators rely on 
System properties to set some values, this is not entirely surprising.  
I suspect there might be some strange side-effects show up if you trying 
to run applications with both enabled, but the fact the yoko jar file on 
the classpath didn't cause a problem makes life a lot easier.

Rick

Mime
View raw message