geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joe Bohn <joe.b...@earthlink.net>
Subject Re: build failure
Date Tue, 19 Sep 2006 15:09:55 GMT
Correction ... the failure is actually on "bootstrap modules" ... not 
openejb2 (that was what I was building on another machine while typing 
the note :-) ).

Joe


Joe Bohn wrote:
> I think the difference might be when you did a bootstrap clean build.
> 
> I'm hitting the same problem as Manu after I decided that I needed to 
> clean out my repo and run the bootstrap again.  Until then I was running 
> fine with the latest source and only doing mvn install or mvn clean 
> install.  However, after cleaning out the repo I can't get openejb2 to 
> build successfully due to the tranql dependency (seems strange that 
> we're looking for a 1.0-SNAPSHOT version of tranql-parent).
> 
> Joe
> 
> 
> Vamsavardhana Reddy wrote:
> 
>> Manu,
>>
>> I followed the steps from wiki page.  Initially I ran into some 
>> problems with JAVA_HOME variable etc.  I have now set it to the SUN 
>> JDK.  I do not know if this variable has any relevance here, but take 
>> no chances.  I have run bootstrap in steps.  I could not get the build 
>> going fine within the first attempt.  The last bootstrap I ran was 
>> "bootstrap minimal".  Afterwards it is working fine for me.  Now I run 
>> "mvn -o install"  and if there are any failures, I run w/o -o.
>>
>> Regards,
>> Vamsi
>>
>> On 9/19/06, *Manu George* <manu.t.george@gmail.com 
>> <mailto:manu.t.george@gmail.com>> wrote:
>>
>>     Hi Vamsi/Lasantha,
>>                   I am having the latest revision(447787). I followed the
>>     steps in the wiki and did a build by separately calling
>>        1.  bootstrap clean
>>        2. bootstrap specs
>>        3. bootstrap modules
>>        4. bootstrap openejb2
>>        5. bootstrap assemble
>>
>>     My sources are in C:\g\trunk. bootstrap assemble fails and then gives
>>     the build successful message as I have shown. I used Sun JDK 1.4.2_12
>>     for building and 1.5 for building specs.
>>     I am doing the m2 build for the first time. Any idea on what may be
>>     going wrong? Did you follow the same steps as in wiki or different
>>     ones? I am aware of the changes Vamsi made but are you also following
>>     different steps Lasantha?
>>
>>     Thanks
>>     Manu
>>
>>     On 9/19/06, Lasantha Ranaweera <lasantha@opensource.lk
>>     <mailto:lasantha@opensource.lk>> wrote:
>>      > Yes I agree with Vamsi. It works correctly for me too with
>>     reversion 447778.
>>      >
>>      > Vamsavardhana Reddy wrote:
>>      > > Hi Manu,
>>      > >
>>      > > I did an svn update on the trunk and then ran a build.  The
>>     build was
>>      > > successful.  Are you sure you have the latest source files?
>>      > >
>>      > > Regards,
>>      > > Vamsi
>>      > >
>>      > > On 9/19/06, *Manu George* < manu.t.george@gmail.com
>>     <mailto:manu.t.george@gmail.com>
>>      > > <mailto: manu.t.george@gmail.com
>>     <mailto:manu.t.george@gmail.com>>> wrote:
>>      > >
>>      > >     Hi,
>>      > >        When i am building the trunk using Maven 2 I am 
>> getting the
>>      > >     following error.
>>      > >     Also even though the build is failing it says build
>>     successful. I get
>>      > >     this when I run bootstrap assemble. The preceding steps all
>>     showed
>>      > >     build successful
>>      > >
>>      > >     Downloading:
>>      > >        
>> http://people.apache.org/repo/m1-snapshot-repository/org.tranql/pom
>>      > >     s/tranql-parent-1.0-SNAPSHOT.pom
>>      > >     [WARNING] Unable to get resource from repository
>>      > >     apache-snapshots-m1 ( http://peo
>>      > >     ple.apache.org/repo/m1-snapshot-repository
>>     <http://ple.apache.org/repo/m1-snapshot-repository>
>>      > >     < http://ple.apache.org/repo/m1-snapshot-repository>)
>>      > >     Downloading:
>>      > >        
>> http://people.apache.org/repo/m2-snapshot-repository/org/tranql/tra
>>     <http://people.apache.org/repo/m2-snapshot-repository/org/tranql/tra>
>>      > >     nql-parent/1.0-SNAPSHOT/tranql-parent-1.0-SNAPSHOT.pom
>>      > >     [WARNING] Unable to get resource from repository
>>     apache-snapshots
>>      > >     ( http://people
>>      > >     .apache.org/repo/m2-snapshot-repository)
>>      > >     Downloading:
>>      > >        
>> http://snapshots.repository.codehaus.org/org/tranql/tranql-parent/1
>>     <http://snapshots.repository.codehaus.org/org/tranql/tranql-parent/1>
>>      > >     .0-SNAPSHOT/tranql-parent-1.0-SNAPSHOT.pom
>>      > >     [WARNING] Unable to get resource from repository
>>      > >     codehaus-snapshots ( http://snap < http://snap>
>>      > >     shots.repository.codehaus.org
>>     <http://shots.repository.codehaus.org> <
>>     http://shots.repository.codehaus.org>)
>>      > >     Downloading:
>>      > >        
>> http://people.apache.org/maven-snapshot-repository/org/tranql/tranq
>>     <http://people.apache.org/maven-snapshot-repository/org/tranql/tranq>
>>      > >     <
>>     http://people.apache.org/maven-snapshot-repository/org/tranql/tranq>
>>      > >     l-parent/1.0-SNAPSHOT/tranql-parent-1.0-SNAPSHOT.pom
>>      > >     [WARNING] Unable to get resource from repository
>>     apache.snapshots
>>      > >     (http://people
>>      > >     .apache.org/maven-snapshot-repository)
>>      > >     [INFO]
>>      > >        
>> ------------------------------------------------------------------------
>>
>>      > >
>>      > >     [ERROR] BUILD ERROR
>>      > >     [INFO]
>>      > >        
>> ------------------------------------------------------------------------
>>      > >     [INFO] Failed to resolve artifact.
>>      > >     GroupId: org.tranql
>>      > >     ArtifactId: tranql-parent
>>      > >     Version: 1.0-SNAPSHOT
>>      > >     Reason: Unable to download the artifact from any repository
>>      > >       org.tranql:tranql-parent:pom:1.0-SNAPSHOT
>>      > >     from the specified remote repositories:
>>      > >       central (http://repo1.maven.org/maven2
>>     <http://repo1.maven.org/maven2>
>>      > >     < http://repo1.maven.org/maven2>),
>>      > >       apache.snapshots
>>      > >     ( http://people.apache.org/maven-snapshot-repository),
>>      > >       codehaus ( http://repository.codehaus.org
>>      > >     < http://repository.codehaus.org>),
>>      > >       apache-snapshots
>>      > >     ( http://people.apache.org/repo/m2-snapshot-repository),
>>      > >       codehaus-snapshots (
>>     http://snapshots.repository.codehaus.org
>>     <http://snapshots.repository.codehaus.org>),
>>      > >       apache-snapshots-m1
>>      > >     (http://people.apache.org/repo/m1-snapshot-repository
>>     <http://people.apache.org/repo/m1-snapshot-repository>)
>>      > >     [INFO]
>>      > >        
>> ------------------------------------------------------------------------
>>
>>      > >
>>      > >     [INFO] For more information, run Maven with the -e switch
>>      > >     [INFO]
>>      > >        
>> ------------------------------------------------------------------------
>>      > >     [INFO] Total time: 28 seconds
>>      > >     [INFO] Finished at: Tue Sep 19 12:07:00 IST 2006
>>      > >     [INFO] Final Memory: 31M/55M
>>      > >     [INFO]
>>      > >        
>> ------------------------------------------------------------------------
>>
>>      > >
>>      > >     Thanks
>>      > >     Manu
>>      > >     BUILD SUCCESSFUL
>>      > >
>>      > >
>>      >
>>      >
>>
>>
> 
> 

Mime
View raw message