geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joe Bohn <joe.b...@earthlink.net>
Subject Re: fail bootstrap early with wrong jdk
Date Wed, 13 Sep 2006 14:35:51 GMT
Funny you should put this out just now.

I was just about to ask if we needed to start running bootstrap 
specifically using JDK 1.5.

I just did a fresh checkout and attempted to build specs via "bootstrap 
specs".  I'm suspecting that the introduction of the EE 5 specs mean 
that we need to start building with JDK 1.5 (in which case failing a 
bootstrap for using JDK 1.5 would be a bad thing).   However, I haven't 
dug into this error yet so it could be something completely different.

Here's the error that I received:

[INFO] 
----------------------------------------------------------------------------
[INFO] Building JPA 1.0
[INFO]    task-segment: [install]
[INFO] 
----------------------------------------------------------------------------
[INFO] [resources:resources]
[INFO] Using default encoding to copy filtered resources.
[INFO] [compiler:compile]
Compiling 91 source files to 
C:\apache\geronimo\trunk\target\external\specs\geronimo-jpa_3.0_spec\target\classes
[INFO] 
------------------------------------------------------------------------
[ERROR] BUILD FAILURE
[INFO] 
------------------------------------------------------------------------
[INFO] Compilation failure
Failure executing javac, but could not parse the error:
javac: invalid target release: 1.5
Usage: javac <options> <source files>



Joe



Bill Dudney wrote:
> I think we should fail the bootstrap early if using jdk 1.5 as well  as 
> failing the maven build.
> 
> http://issues.apache.org/jira/browse/GERONIMO-2403
> 
> has a patch attached that works, but there might be a way to reuse  the 
> mojo that Jason wrote, not sure...
> 
> Thanks,
> 
> -bd-
> 
> 

Mime
View raw message