geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Jencks <david_jen...@yahoo.com>
Subject Re: Build error with bootstrap assemble
Date Sat, 30 Sep 2006 15:43:03 GMT
I've tried mvn -U, rebuilding genesis locally, and a bunch of other  
things and I'm still getting this error too.

My top level pom appears to have something slightly different:

         <plugins>
             <plugin>
                 <groupId>org.apache.geronimo.genesis.plugins</groupId>
                 <artifactId>tools-maven-plugin</artifactId>
                 <executions>
                     <execution>
                         <id>validate-java-version</id>
                         <phase>validate</phase>
                         <goals>
                             <goal>require-java-version</goal>
                         </goals>
                         <configuration>
                             <version>1.4*</version>
                         </configuration>
                     </execution>

                     <!--
                     NOTE: This will copy LICENSE.txt and NOTICE.txt  
to classes/META-INF.

                           Its a itty-bitty HACK to avoid adding  
resource definitions to
                           the build, which causes the Eclipse plugin  
to generate invalid
                           .classpath files. :-(
                     -->
                     <execution>
                         <id>install-legal-files</id>
                         <phase>generate-resources</phase>
                         <goals>
                             <goal>copy-legal-files</goal>
                         </goals>
                     </execution>
                 </executions>
             </plugin>

any ideas?

thanks
david jencks


On Sep 30, 2006, at 1:50 AM, Jason Dillon wrote:

> Run `mvn -U` to make sure you have the latest snapshots.... or `rm - 
> rf ~/.m2/repository/org/apache/geronimo/genesis/`.
>
> Genesis tools-maven-plugin was updated earlier to add some new  
> packagings.
>
> Also make sure the top-level pom.xml is up to date, it could have:
>
> <plugin>
>                 <groupId>org.apache.geronimo.genesis.plugins</groupId>
>                 <artifactId>tools-maven-plugin</artifactId>
>
>                 <!-- Tools includes custom packagings, install as  
> extention to pick them up -->
>                 <extensions>true</extensions>
> ...
>
> --jason
>
>
> On Sep 30, 2006, at 1:19 AM, Vamsavardhana Reddy wrote:
>
>> I am getting the following error when running bootstrap assmble.   
>> Any suggestions on how to overcome this?
>>
>> [INFO] Building Geronimo Assemblies :: Minimal Framework
>> [INFO]    task-segment: [install]
>> [INFO]  
>> --------------------------------------------------------------------- 
>> ----
>> ---
>> [INFO]  
>> --------------------------------------------------------------------- 
>> ---
>> [ERROR] BUILD ERROR
>> [INFO]  
>> --------------------------------------------------------------------- 
>> ---
>> [INFO] Cannot find lifecycle mapping for packaging: 'application- 
>> assembly'.
>> Component descriptor cannot be found in the component repository:  
>> org.apache.mav
>> en.lifecycle.mapping.LifecycleMappingapplication-assembly.
>> [INFO]  
>> --------------------------------------------------------------------- 
>> ---
>> [INFO] For more information, run Maven with the -e switch
>> [INFO]  
>> --------------------------------------------------------------------- 
>> ---
>> [INFO] Total time: 6 minutes 44 seconds
>> [INFO] Finished at: Sat Sep 30 13:44:24 IST 2006
>> [INFO] Final Memory: 61M/111M
>


Mime
View raw message