geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Paul McMahan" <paulmcma...@gmail.com>
Subject Re: wadi integration for Jetty seems to have broken session management for jetty
Date Thu, 21 Sep 2006 16:42:20 GMT
Hey Gianny,  I can also recreate the problem with Jetty.  Its
intermittent and hard to diagnose, but when I see the problem its just
like Joe described.  I thought it might be due to the changes made in
GERONIMO-2329 but reverting that change didn't seem to fix the
problem.

Paul

On 9/20/06, Joe Bohn <joe.bohn@earthlink.net> wrote:
>
> Hi Gianny,
>
> Thanks for the response.  The problem I'm seeing is pretty obvious and
> doesn't require any setup.  Does this match the problem that David J
> reported?  For me it happens almost every time, although there are cases
> where things seems to magically work (but they are more rare). I believe
> that Paul has also encountered this problem.  It seems like the session
> id that is received at the browser isn't recognized when returned to the
> server and so a new session is returned.  I haven't had a chance to dig
> in further yet.
>
> Joe
>
>
> Gianny Damour wrote:
> > Hi Joe,
> >
> > David J. raised a problem with the integration code and I am simply  not
> > able to reproduce it. I am running the console with the Jetty
> > integration code since now many weeks (I tested all the Javascript  plus
> > JMX Portlet with the integration code) and I have not observed  this
> > problem. I will review the integration code tonight. Are there  things
> > that I need to do to reproduce?
> >
> > Sorry for this problem,
> > Gianny
> >
> > On 21/09/2006, at 2:49 AM, Joe Bohn wrote:
> >
> >>
> >> The session management for Jetty in trunk is screwed up and I  suspect
> >> that the wadi integration may have been the cause.
> >>
> >> To see the symptom bring up the web console under jetty.  It will
> >> take several attempts to get past the login prompt (2-3).   Once  you
> >> do get past the login prompt the next click (sometimes it take  two)
> >> will send you back to the login prompt again.  And so it  continues
> >> .... constantly being tossed back to the login prompt  because I
> >> suspect the session is being lost. No message are sent to  the console
> >> or the logs.
> >>
> >> I have noticed that if I launch another browser (and so create a
> >> second session) I can usually get one of the sessions to stick  around
> >> long enough to do some real activities (usually the one  associated
> >> with the first browser session).
> >>
> >> This is only a problem on Jetty and not Tomcat.
> >>
> >> I'll keep poking around but I was wondering if somebody (Gianny?)
> >> knew some potential areas that may have been the culprit.
> >>
> >> Thanks,
> >> Joe
> >>
> >
> >
> >
>

Mime
View raw message