geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Paul McMahan" <paulmcma...@gmail.com>
Subject Re: [VOTE] 1.1.1-rc2 Release
Date Thu, 07 Sep 2006 21:35:23 GMT
OK thanks Matt now I understand the timing.  I copied the jacc spec,
j2ee schema, and ejb jars into my local maven repo and built the
src.tar.gz on linux and the src.zip on windows.  Started up the server
and did a quick smoke test.  Things look ok, except for deploying a
database pool which leads to the JACC error that was found in rc1 :

java.lang.IllegalArgumentException: Qualifier patterns must be present
when first URLPattern is an exact pattern
        at javax.security.jacc.URLPatternSpec.<init>(URLPatternSpec.java:98)
        at javax.security.jacc.WebResourcePermission.<init>(WebResourcePermission.java:47)

Since others aren't hitting this error when using the binary distro I
assume its happening because the jacc spec jar I copied from ~hogstrom
into my local repo is backlevel, which reading back through this
thread I see that Vamsi noticed the same thing.

IIUC that error will be cleared up as soon as the spec jars are
published, which (due to the race condition) can't happen until the
release is finalized,  so +1 from me!  :-)

Best wishes,
Paul

On 9/6/06, Matt Hogstrom <matt@hogstrom.org> wrote:
> Grab the jar from http://people.apache.org/~hogstrom/1.1.1-rc2/geronimo-j2ee-jacc_1.0_spec-1.1.1-rc2.jar
>   and place it in your local repo.  Don't forget to rename it to the same name minus
the -rc2.
> Since this jar is part of the release we have a bit of a race condition.
>
> Paul McMahan wrote:
> > Trying to build the src from
> >
> > http://people.apache.org/~hogstrom/1.1.1-rc2/geronimo-1.1.1-rc2-src.tar.gz
> > on linux I get this error :
> >
> > +----------------------------------------
> > | geronimo and geronimo-plugins Geronimo :: Security
> > | Memory: 11M/17M
> > +----------------------------------------
> > DEPRECATED: the default goal should be specified in the <build>
> > section of project.xml instead of maven.xml
> > DEPRECATED: the default goal should be specified in the <build>
> > section of project.xml instead of maven.xml
> >
> > build:end:
> >
> > Attempting to download geronimo-j2ee-jacc_1.0_spec-1.1.1.jar.
> > WARNING: Failed to download geronimo-j2ee-jacc_1.0_spec-1.1.1.jar.
> >
> > BUILD FAILED
> > File...... /home/pmcmahan/foo/geronimo-1.1.1-rc2-src/maven.xml
> > Element... maven:reactor
> > Line...... 43
> > Column.... -1
> > The build cannot continue because of the following unsatisfied dependency:
> > geronimo-j2ee-jacc_1.0_spec-1.1.1.jar
> >
> > Is this just due to a timing window where the specs haven't been
> > published until the release is ready?
> >
> >
> > Trying to build the src from
> >    http://people.apache.org/~hogstrom/1.1.1-rc2/geronimo-1.1.1-rc2-src.zip
> > on windows I get this error in Geronimo::Maven Dependency Plugin:
> >
> > 15:20:10,031 INFO  [PluginManager] Artifact 'C:\Documents and
> > Settings\pmcmahan\
> > .maven\repository\maven\jars\maven-1.0.2.jar' not found to add to classpath
> >
> > That leads to some class not found errors when compiling
> > GenerateServiceXml.java.  This seems to be a result of building with
> > maven1.1b3.  Downgrading to maven1.1b2 got me further, to the error I
> > saw on linux described above.
> >
> >
> > Best wishes,
> > Paul
> >
> >
> > On 9/6/06, Vamsavardhana Reddy <c1vamsi1c@gmail.com> wrote:
> >> http://people.apache.org/~hogstrom/1.1.1-
> >> rc2/geronimo-j2ee-jacc_1.0_spec-1.1.1-rc2.jar is not same
> >> as the one that is in the binary distributions.  I have checked this
> >> in the
> >> context of GERONIMO-2376 .
> >>
> >>  Vamsi
> >>
> >>
> >> On 9/6/06, Matt Hogstrom <matt@hogstrom.org> wrote:
> >> > The changes pointed out by Bill have been incorporated (crossing my
> >> fingers).  I have not received
> >> > any other comments so I'm hoping that others have looked.  Please
> >> review
> >> these items and cast your
> >> > votes in this thread.
> >> >
> >> > Thanks in advance for your time and attention.
> >> >
> >> > Vote ends Monday morning at 0600 Eastern Time.  If there are issues in
> >> advance of that date a new RC
> >> > will be spun up and a new vote started.
> >> >
> >> > *Source*
> >> >
> >> http://people.apache.org/~hogstrom/1.1.1-rc2/geronimo-1.1.1-rc2-src.tar.gz
> >>
> >> >
> >> http://people.apache.org/~hogstrom/1.1.1-rc2/geronimo-1.1.1-rc2-src.zip
> >> >
> >> > *Specifications*
> >> >
> >> http://people.apache.org/~hogstrom/1.1.1-rc2/geronimo-j2ee-jacc_1.0_spec-1.1.1-rc2.jar
> >>
> >> >
> >> http://people.apache.org/~hogstrom/1.1.1-rc2/geronimo-schema-j2ee_1.4-1.0-src.jar
> >>
> >> >
> >> http://people.apache.org/~hogstrom/1.1.1-rc2/geronimo-schema-j2ee_1.4-1.0.jar
> >>
> >> >
> >> > *Distributions*
> >> >
> >> http://people.apache.org/~hogstrom/1.1.1-rc2/geronimo-jetty-j2ee-1.1.1-rc2.tar.gz
> >>
> >> >
> >> http://people.apache.org/~hogstrom/1.1.1-rc2/geronimo-jetty-j2ee-1.1.1-rc2.zip
> >>
> >> >
> >> http://people.apache.org/~hogstrom/1.1.1-rc2/geronimo-jetty-minimal-1.1.1-rc2.tar.gz
> >>
> >> >
> >> http://people.apache.org/~hogstrom/1.1.1-rc2/geronimo-jetty-minimal-1.1.1-rc2.zip
> >>
> >> >
> >> http://people.apache.org/~hogstrom/1.1.1-rc2/geronimo-tomcat-j2ee-1.1.1-rc2.tar.gz
> >>
> >> >
> >> http://people.apache.org/~hogstrom/1.1.1-rc2/geronimo-tomcat-j2ee-1.1.1-rc2.zip
> >>
> >> >
> >> http://people.apache.org/~hogstrom/1.1.1-rc2/geronimo-tomcat-minimal-1.1.1-rc2.tar.gz
> >>
> >> >
> >> http://people.apache.org/~hogstrom/1.1.1-rc2/geronimo-tomcat-minimal-1.1.1-rc2.zip
> >>
> >> >
> >> > *Other Items*
> >> >
> >> http://people.apache.org/~hogstrom/1.1.1-rc2/openejb-builder-2.1.1.jar
> >> >
> >> http://people.apache.org/~hogstrom/1.1.1-rc2/openejb-core-2.1.1.jar
> >> >
> >> http://people.apache.org/~hogstrom/1.1.1-rc2/openejb-pkgen-builder-2.1.1.jar
> >>
> >> >
> >>
> >>
> >
> >
> >
>

Mime
View raw message