geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jacek Laskowski" <ja...@laskowski.net.pl>
Subject Re: fail bootstrap early with wrong jdk
Date Wed, 13 Sep 2006 14:43:55 GMT
On 9/13/06, Joe Bohn <joe.bohn@earthlink.net> wrote:

> I just did a fresh checkout and attempted to build specs via "bootstrap
> specs".  I'm suspecting that the introduction of the EE 5 specs mean
> that we need to start building with JDK 1.5 (in which case failing a
> bootstrap for using JDK 1.5 would be a bad thing).   However, I haven't
> dug into this error yet so it could be something completely different.
...
> Failure executing javac, but could not parse the error:
> javac: invalid target release: 1.5
> Usage: javac <options> <source files>

That's yet another reason to whack bootstrap if it's not used heavily.
It seems it's not as noone's reported the issue before.

I could build Geronimo, OpenEJB 2 and Specs with no bootstrap and .m2
local repo and wonder whether we really need the bootstrap script yet?

Jacek

-- 
Jacek Laskowski
http://www.laskowski.net.pl

Mime
View raw message