geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jacek Laskowski" <ja...@laskowski.net.pl>
Subject Re: openejb-builder test failure
Date Fri, 08 Sep 2006 15:12:03 GMT
On 9/8/06, Joe Bohn <joe.bohn@earthlink.net> wrote:
> The pieces are all starting to come together.

Great! ;-)

> I was first getting the error that Sergey referenced and which I first
> referenced in this post:
> http://marc.theaimsgroup.com/?l=geronimo-dev&m=115653241007061&w=2

So was I.

> I was actually proposing skipping the tests to get around that error
> because when I added the getName() method I hit the MalformedURL error
> that Jacek mentioned (and I posted about here).
>
> http://marc.theaimsgroup.com/?l=geronimo-dev&m=115680051431478&w=2
>
> I wasn't aware that this was a known problem and changing the repository
> path would resolve it.

The first time we hit this was in OpenEJB 3 and Dave B. fixed it
easily for it was only in one unit test. I remember Dave mentioned it
had been fixed in OpenEJB 2, too, but seems it was not (I guess Dave
had yanked MS Windows and installed MacOS or Linux ;-))

> Thank you Jacek for pointing me to the openejb
> issue!  I changed my repo and now it seems that I can build successfully
> both without the getName() method errors and without the MalformedURL
> exceptions.

Does it mean that once you set maven.repo.local to a non-spaced path
the build worked well?

> Does anybody know if there is an environment variable that I can set for
> the m2 repo so that I don't have to modify the build scripts?

You can run m2 with localRepository set in ~/.m2/settings.xml as
described at http://maven.apache.org/ref/current/maven-settings/settings.html#class_settings.
Look at localRepository setting. It should do the trick. Give it a
whirl and report back (so I won't have to dig into surefire plugin and
fix the classpath issue ;-) I just can't believe it's merely us who
experience the issue!).

Jacek

-- 
Jacek Laskowski
http://www.laskowski.net.pl

Mime
View raw message