geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Guillaume Nodet" <gno...@gmail.com>
Subject Re: Car plugin
Date Tue, 22 Aug 2006 13:13:56 GMT
I guess I was misunderstood.
I' m using the maven 2 plugin in trunk to build a plugin for Geronimo 1.1.
This is the only way, because there is no maven 2 plugin for G 1.1.
Everything was working fine until this recent change.

Adding a property to specify the target geronimo version seems to do the trick.
So i can now have:

<module xmlns="http://geronimo.apache.org/xml/ns/deployment-1.1">
  <environment>

instead of

<module xmlns="http://geronimo.apache.org/xml/ns/deployment-1.1">
  <environment xmlns="http://geronimo.apache.org/xml/ns/deployment-1.2">

Btw, I' m wondering why the PlanProcessorMojo only overrides the environmnet
tag, and not the module one.


On 8/22/06, Jacek Laskowski <jacek@laskowski.net.pl> wrote:
> On 8/22/06, Guillaume Nodet <gnodet@gmail.com> wrote:
> > I recently experienced some problems [1] when building Geronimo 1.1
> > plugins using
> > the car-maven-plugin.
>
> I think a solution may be to build the maven plugin locally from 1.1
> sources and build Geronimo 1.1 then. It seems you've been trying to
> run the build online and thus all the deps (the maven plugin
> including) is pulled down too. For it's an incompatible version, the
> build blows up.
>
> Just a wild guess, but may be of help. Report back! ;-)
>
> Jacek
>
> --
> Jacek Laskowski
> http://www.laskowski.net.pl
>


-- 
Cheers,
Guillaume Nodet

Mime
View raw message